createMapLayerTree MethodStatic

Creates a MapLayerTileTreeReference for this map layer format.

createMapLayerTree(_layerSettings: MapLayerSettings, _layerIndex: number, _iModel: IModelConnection): undefined | MapLayerTileTreeReference

@returns Returns the new tile tree reference.

Parameter Type Description
_layerSettings MapLayerSettings Map layer settings that are applied to the MapLayerTileTreeReference.
_layerIndex number The index of the associated map layer.
_iModel IModelConnection The iModel containing the MapLayerTileTreeReference.

Returns - undefined | MapLayerTileTreeReference

Returns the new tile tree reference.

Defined in

Last Updated: 16 April, 2024