Decorations Class

A set of RenderGraphics and CanvasDecorations produced by Tools and Decorators, used to decorate the contents of a Viewport.

Implements

Methods

Name Description
constructor(): Decorations    
dispose(): void    

Properties

Name Type Description
canvasDecorations undefined | CanvasDecorationList    
normal Accessor undefined | GraphicList Decorations drawn as if they were part of the scene.  
skyBox Accessor undefined | RenderGraphic A view decoration created from a SkyBox rendered behind all other geometry to provide environmental context.  
viewBackground Accessor undefined | RenderGraphic A view decoration drawn as the background of the view.  
viewOverlay Accessor undefined | GraphicList Overlay decorations drawn in view coordinates.  
world Accessor undefined | GraphicList Decorations drawn as if they were part of the world, but ignoring the view's ViewFlags.  
worldOverlay Accessor undefined | GraphicList Overlay decorations drawn in world coordinates.  

Defined in

Last Updated: 15 March, 2024