RenderContext Class

Provides context for producing RenderGraphics for drawing within a Viewport.

Extended by

Methods

Name Description
constructor(vp: Viewport, frustum?: Frustum): RenderContext    
createBranch(branch: GraphicBranch, location: Transform): RenderGraphic Create a RenderGraphic which groups a set of graphics into a node in a scene graph, applying to each a transform and optional clip volume and symbology overrides.  
createGraphicBranch(branch: GraphicBranch, location: Transform, opts?: GraphicBranchOptions): RenderGraphic Create a graphic from a GraphicBranch.  
createSceneGraphicBuilder(transform?: Transform): GraphicBuilder Create a builder for creating a GraphicType.Scene RenderGraphic for rendering within this context's Viewport.  
getPixelSizeAtPoint(inPoint?: Point3d): number Given a point in world coordinates, determine approximately how many pixels it occupies on screen based on this context's frustum.  

Properties

Name Type Description
frustum Readonly Frustum Frustum extracted from the context's Viewport.  
frustumPlanes Readonly FrustumPlanes Frustum planes extracted from the context's Viewport.  
renderSystem Accessor ReadOnly RenderSystem The RenderSystem being used to produce graphics for this context.  
viewFlags Readonly ViewFlags ViewFlags extracted from the context's Viewport.  
viewport Accessor ReadOnly Viewport The Viewport associated with this context.  

Defined in

Last Updated: 15 March, 2024