SelectionTool Class

Tool for picking a set of elements of interest, selected by the user.

Extends

Methods

Name Description
constructor(..._args: any[]): SelectionTool    
applyToolSettingPropertyChange(updatedValue: DialogPropertySyncItem): Promise<boolean> Used to send changes from UI back to Tool  
autoLockTarget(): void Called on data button down event to lock the tool to its current target model.  
decorate(context: DecorateContext): void Called to allow an active tool to display non-element decorations in overlay mode.  
filterHit(hit: HitDetail, out?: LocateResponse): Promise<LocateFilterStatus> Invoked to allow tools to filter which elements can be located.  
initSelectTool(): void Protected    
onCleanup(): Promise<void> Invoked when the tool becomes no longer active, to perform additional cleanup logic  
onDataButtonUp(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is released.  
onModifierKeyTransition(_wentDown: boolean, modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Called when Control, Shift, or Alt modifier keys are pressed or released.  
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Invoked when the button is released after onMouseStartDrag.  
onMouseMotion(ev: BeButtonEvent): Promise<void> Invoked when the cursor is moving  
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> Invoked when the cursor begins moving while a button is depressed.  
onPostInstall(): Promise<void> Override to execute additional logic after tool becomes active  
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
onRestartTool(): Promise<void> Called when an external event may invalidate the current tool's state.  
onSuspend(): Promise<void> Notification of a ViewTool or InputCollector starting and this tool is being suspended.  
onTouchCancel(ev: BeTouchEvent): Promise<void> Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.  
onTouchComplete(ev: BeTouchEvent): Promise<void> Called when the last touch point is removed from the surface completing the current gesture.  
onTouchMove(ev: BeTouchEvent): Promise<void> Called when a touch point moves along the surface.  
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.  
onUnsuspend(): Promise<void> Notification of a ViewTool or InputCollector exiting and this tool is being unsuspended.  
processHit(ev: BeButtonEvent, hit: HitDetail): Promise<EventHandled>    
processMiss(_ev: BeButtonEvent): boolean Protected    
processSelection(elementId: Id64Arg, process: SelectionProcessing): Promise<boolean>    
requireWriteableTarget(): boolean Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements.  
selectByPointsEnd(ev: BeButtonEvent): boolean Protected    
selectByPointsProcess(origin: Point3d, corner: Point3d, ev: BeButtonEvent, method: SelectionMethod, overlap: boolean): void Protected    
selectByPointsStart(ev: BeButtonEvent): boolean Protected    
selectDecoration(ev: BeButtonEvent, currHit?: HitDetail): Promise<EventHandled>    
showPrompt(mode: SelectionMode, method: SelectionMethod): void Protected    
supplyToolSettingsProperties(): undefined | DialogItem[] Used to supply DefaultToolSettingProvider with a list of properties to use to generate ToolSettings.  
updateSelection(elementId: Id64Arg, process: SelectionProcessing): boolean    
useOverlapSelection(ev: BeButtonEvent): boolean Protected    
wantEditManipulators(): boolean Protected    
wantPickableDecorations(): boolean Protected    
wantSelectionClearOnMiss(_ev: BeButtonEvent): boolean Protected    
wantToolSettings(): boolean Protected    
startTool(): Promise<boolean> Static    

Inherited methods

Name Inherited from Description
beginDynamics(): void PrimitiveTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> PrimitiveTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void PrimitiveTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean PrimitiveTool Helper method for responding to a tool setting property value change by updating saved settings.
decorateSuspended(_context: DecorateContext): void PrimitiveTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void PrimitiveTool Call to terminate dynamics mode.
exitTool(): Promise<void> PrimitiveTool  
getCurrentButtonEvent(ev: BeButtonEvent): void PrimitiveTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps PrimitiveTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string PrimitiveTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> PrimitiveTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> PrimitiveTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initLocateElements(enableLocate: boolean = true, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void PrimitiveTool Helper method for tools that need to locate existing elements.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void PrimitiveTool Helper method to establish initial values for tool setting properties from saved settings.
isCompatibleViewport(vp: undefined | Viewport, isSelectedViewChange: boolean): boolean PrimitiveTool Determine whether the supplied Viewport is compatible with this tool.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean PrimitiveTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onDataButtonDown(_ev: BeButtonEvent): Promise<EventHandled> PrimitiveTool Invoked when the data button is pressed.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void PrimitiveTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> PrimitiveTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> PrimitiveTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> PrimitiveTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> PrimitiveTool Invoked when the middle mouse button is released.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> PrimitiveTool Invoked when the mouse wheel moves.
onRedoPreviousStep(): Promise<boolean> PrimitiveTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> PrimitiveTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> PrimitiveTool Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: undefined | Viewport, current: undefined | Viewport): Promise<void> PrimitiveTool Called when active view changes.
onTouchEnd(_ev: BeTouchEvent): Promise<void> PrimitiveTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchStart(_ev: BeTouchEvent): Promise<void> PrimitiveTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> PrimitiveTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> PrimitiveTool Called to reverse to a previous tool state (ex.
parseAndRun(..._args: string[]): Promise<boolean> PrimitiveTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void PrimitiveTool Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): Promise<boolean> PrimitiveTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> PrimitiveTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void PrimitiveTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean PrimitiveTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static PrimitiveTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_isSelectByPoints Protected boolean    
_isSuspended Protected boolean    
_points ProtectedReadonly Point3d[]    
hidden Static boolean If true, this Tool will not appear in the list from ToolRegistry.getToolList.  
iconSpec Static string The icon for this Tool.  
selectionMethod Accessor SelectionMethod    
selectionMode Accessor SelectionMode    
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
briefcase Accessor ReadOnly undefined | BriefcaseConnection PrimitiveTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target PrimitiveTool.iModel is a briefcase.
description Accessor ReadOnly string PrimitiveTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string PrimitiveTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string PrimitiveTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string PrimitiveTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string PrimitiveTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PrimitiveTool.keyin is returned.
iconSpec Accessor ReadOnly string PrimitiveTool Get the iconSpec from this Tool's class.
iModel Accessor ReadOnly IModelConnection PrimitiveTool Get the iModel on which this tool operates.
isControlDown Accessor ReadOnly boolean PrimitiveTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor ReadOnly boolean PrimitiveTool Call to find out if dynamics are currently active.
keyin Accessor ReadOnly string PrimitiveTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string PrimitiveTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor StaticReadOnly undefined | number PrimitiveTool The maximum number of arguments allowed by PrimitiveTool.parseAndRun, or undefined if there is no maximum.
If subclasses override PrimitiveTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor StaticReadOnly number PrimitiveTool The minimum number of arguments allowed by PrimitiveTool.parseAndRun. If subclasses override PrimitiveTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static string PrimitiveTool The namespace that provides localized strings for this Tool.
receivedDownEvent boolean PrimitiveTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked boolean PrimitiveTool  
targetModelId Accessor undefined | string PrimitiveTool  
targetView undefined | Viewport PrimitiveTool The viewport within which the tool operates.
toolId Accessor ReadOnly string PrimitiveTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 16 April, 2024