RealityDataSource Namespace

Utility functions for RealityDataSource

Function

Name Description
RealityDataSource.createKeyFromUrl Create a RealityDataSourceKey from a tilesetUrl.

Defined in

RealityDataSource Interface

This interface provide methods used to access a reality data from a reality data provider

Methods

Name Description
getServiceUrl(iTwinId: undefined | string): Promise<undefined | string> This method returns the URL to obtain the Reality Data properties.  

Properties

Name Type Description
isContextShare Readonly boolean    
key Readonly RealityDataSourceKey    
realityData Readonly undefined | RealityData Metatdata on the reality data source  
realityDataId Readonly undefined | string    
realityDataType Readonly undefined | string The reality data type (e.g.: "RealityMesh3DTiles", OPC, Terrain3DTiles, Cesium3DTiles, ...  

Defined in

Last Updated: 16 April, 2024