TileAdmin Namespace

Interface

Name Description
TileAdmin.Props Describes the configuration of the TileAdmin.
TileAdmin.Statistics Statistics regarding the current and cumulative state of the TileAdmin.

Variable

Name Description
TileAdmin.mobileGpuMemoryLimits The number of bytes of GPU memory associated with the various GpuMemoryLimits for mobile devices.
TileAdmin.nonMobileGpuMemoryLimits The number of bytes of GPU memory associated with the various GpuMemoryLimits for non-mobile devices.

Defined in

TileAdmin Class

Manages Tiles and TileTrees on behalf of IModelApp. Its responsibilities include scheduling requests for tile content via a priority queue; keeping track of and imposing limits upon the amount of GPU memory consumed by tiles; and notifying listeners of tile-related events.

@see - IModelApp.tileAdmin to access the instance of the TileAdmin.

  • TileAdmin.Props to configure the TileAdmin at startup.

Methods

Name Description
addLoadListener(callback: (imodel: IModelConnection) => void): () => void Subscribe to TileAdmin.onTileLoad, TileAdmin.onTileTreeLoad, and TileAdmin.onTileChildrenLoad.  
clearTilesForUser(user: TileUser): void Clears the sets of tiles associated with a TileUser.  
forgetUser(user: TileUser): void Indicates that the TileAdmin should cease tracking the specified TileUser, e.g.  
getMaximumMajorTileFormatVersion(formatVersion?: number): number Given a numeric combined major+minor tile format version (typically obtained from a request to the backend to query the maximum tile format version it supports),  
getNumRequestsForUser(user: TileUser): number Returns the number of pending and active requests associated with the specified user.  
getNumRequestsForViewport(vp: Viewport): number Returns the number of pending and active requests associated with the specified viewport.  
queryVersionInfo(): Promise<Readonly<TileVersionInfo>> Obtain information about the version/format of the tiles supplied by the backend.  
registerUser(user: TileUser): void Indicates that the TileAdmin should track tile requests for the specified TileUser.  
requestElementGraphics(iModel: IModelConnection, requestProps: ElementGraphicsRequestProps): Promise<undefined | Uint8Array> Request graphics for a single element or geometry stream.  
resetStatistics(): void Resets the cumulative (per-session) statistics like totalCompletedRequests, totalEmptyTiles, etc.  
create(props?: TileAdmin.Props): Promise<TileAdmin> Static Create a TileAdmin suitable for passing to IModelApp.startup via IModelAppOptions.tileAdmin to customize aspects of  

Properties

Name Type Description
cesiumIonKey Readonly undefined | string    
channels Readonly TileRequestChannels    
defaultTileSizeModifier Accessor number A default multiplier applied to the size in pixels of a Tile during tile selection for any Viewport.  
gpuMemoryLimit Accessor GpuMemoryLimit The strategy for limiting the amount of GPU memory allocated to Tile graphics.  
maxTotalTileContentBytes Accessor ReadOnly undefined | number The maximum number of bytes of GPU memory that can be allocated to the contents of Tiles.  
onTileChildrenLoad Readonly BeEvent<(parentTile: Tile) => void> Event raised when a request to load a tile's child tiles completes.  
onTileLoad Readonly BeEvent<(tile: Tile) => void> Event raised when a request to load a tile's content completes.  
onTileTreeLoad Readonly BeEvent<(tileTree: TileTreeOwner) => void> Event raised when a request to load a tile tree completes.  
statistics Accessor ReadOnly TileAdmin.Statistics Returns basic statistics about the TileAdmin's current state.  
totalTileContentBytes Accessor ReadOnly number The total number of bytes of GPU memory allocated to Tile contents.  

Defined in

Last Updated: 16 April, 2024