TileRequest Namespace

Enumeration

Name Description
TileRequest.State The states through which a TileRequest proceeds.

Type alias

Name Description
TileRequest.Response The type of a raw response to a request for tile content.
TileRequest.ResponseData The input to Tile.readContent, to be converted into a RenderGraphic.

Defined in

TileRequest Class

Represents a pending or active request to load the contents of a Tile. The request coordinates with the Tile.requestContent to obtain the raw content and Tile.readContent to convert the result into a RenderGraphic. TileRequests are created internally as needed; it is never necessary or useful for external code to create them.

Methods

Name Description
constructor(tile: Tile, user: TileUser): TileRequest Constructor  

Properties

Name Type Description
channel Readonly TileRequestChannel The channel via which the request will be executed.  
isCanceled Accessor ReadOnly boolean True if the request has been canceled.  
isQueued Accessor ReadOnly boolean True if the request has been enqueued but not yet dispatched.  
priority number Determines the order in which pending requests are pulled off the queue to become active.  
state Accessor ReadOnly TileRequest.State The request's current state.  
tile Readonly Tile The requested tile.  
tree Accessor ReadOnly TileTree The tile tree to which the requested Tile belongs.  
viewports Accessor ReadOnly Iterable<Viewport> The set of Viewports that are awaiting the result of this request.  

Defined in

Last Updated: 16 April, 2024