TileRequestChannelStatistics Class

Statistics regarding the current and cumulative state of one or more TileRequestChannels. Useful for monitoring performance and diagnosing problems.

@see - TileRequestChannel.statistics for a specific channel's statistics.

Methods

Name Description
constructor(): TileRequestChannelStatistics    

Properties

Name Type Description
decoding TileContentDecodingStatistics Statistics summarizing time spent decoding tile content.  
numActiveRequests number The number of requests that have been dispatched but not yet completed.  
numCanceled number The number of requests canceled during the most recent update.  
numPendingRequests number The number of queued requests that have not yet been dispatched.  
totalAbortedRequests number The total number of tiles for which content requests were dispatched and then canceled on the backend before completion.  
totalCacheMisses number The total number of tiles whose contents were not found in cloud storage cache and therefore resulted in a backend request to generate the tile content.  
totalCompletedRequests number The total number of completed requests during this session.  
totalDispatchedRequests number The total number of tiles for which content requests were dispatched.  
totalEmptyTiles number The total number of completed requests during this session which produced an empty tile.  
totalFailedRequests number The total number of failed requests during this session.  
totalTimedOutRequests number The total number of timed-out requests during this session.  
totalUndisplayableTiles number The total number of completed requests during this session that produced an undisplayable tile.  

Defined in

Last Updated: 15 March, 2024