TileUsageMarker Class

A marker associated with a Tile to track usage of that tile by any number of TileUsers. The marker tracks:

  • the set of TileUsers by which the tile is in use for some purpose (displayed, preloaded, requested, selected for shadow map, etc); and
  • the most recent time at which any tile user declared its use of the tile. The marker is used to allow tiles to be discarded after they become disused by any tile user, via Tile.prune.

@see Tile.usageMarker.

Methods

Name Description
constructor(): TileUsageMarker Constructs a usage marker with its timepoint set to the current time and its set of TileUsers empty.  
getIsTileInUse(): boolean Returns true if this tile is currently in use by any TileUser.  
isExpired(expirationTime: BeTimePoint): boolean Returns true if this tile is currently in use by no TileUsers and its timestamp pre-dates expirationTime.  
isTimestampExpired(expirationTime: BeTimePoint): boolean Returns true if this tile's timestamp pre-dates expirationTime, without checking if it is in use.  
mark(user: TileUser, time: BeTimePoint): void Updates the timestamp to the specified time and marks the tile as being in use by the specified TileUser.  

Defined in

Last Updated: 16 April, 2024