ViewPose Class

The "pose" for a View describing the viewed area or volume, depending upon whether the view is 2d or 3d.

@see ViewState.savePose to extract a pose from a view and ViewState.applyPose to apply a pose to a view.

@note a ViewPose is immutable.

Extended by

Methods

Name Description
constructor(cameraOn: boolean): ViewPose    
equal(other: ViewPose): boolean Abstract Returns true if this pose is equivalent to the specified other pose.  
equalState(view: ViewState): boolean Abstract Returns true if this pose is equivalent to the pose represented by the specified ViewState.  

Properties

Name Type Description
cameraOn boolean True if the camera is enabled.  
center Accessor ReadOnly Point3d Computes the center of the viewed volume.  
extents Abstract Vector3d The extents of the view in CoordSystem.World coordinates.  
origin Abstract Point3d The origin of the view in CoordSystem.World coordinates.  
rotation Abstract Matrix3d The 3x3 ortho-normal rotation matrix of the view.  
target Accessor ReadOnly Point3d Returns the target point of the view.  
undoTime undefined | BeTimePoint The time at which this pose was created, if it was saved into a Viewport's undo stack.  
zVec Accessor ReadOnly Vector3d Computes the Z vector of the ViewPose.rotation matrix.  

Defined in

Last Updated: 16 April, 2024