MaskBackgroundMapByModelTool Class

Tool to mask background map by geometric models

Extends

Methods

Name Description
constructor(..._args: any[]): MaskBackgroundMapByModelTool    
applyMask(vp: ScreenViewport): void Protected    
createToolInstance(): PlanarMaskBaseTool Protected    
showPrompt(): void Protected    
targetModelRequired(): boolean Protected    

Inherited methods

Name Inherited from Description
allowSelection(): boolean Protected PlanarMaskBaseTool  
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> PlanarMaskBaseTool Used to receive property changes from UI.
autoLockTarget(): void PlanarMaskBaseTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void PlanarMaskBaseTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> PlanarMaskBaseTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void PlanarMaskBaseTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean PlanarMaskBaseTool Helper method for responding to a tool setting property value change by updating saved settings.
createElementMask(option: "include" | "exclude"): PlanarClipMaskSettings Protected PlanarMaskBaseTool  
createModelMask(): PlanarClipMaskSettings Protected PlanarMaskBaseTool  
createSubCategoryMask(): PlanarClipMaskSettings Protected PlanarMaskBaseTool  
decorate(_context: DecorateContext): void PlanarMaskBaseTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void PlanarMaskBaseTool Called to allow a suspended tool to display non-element decorations in overlay mode.
elementRequired(): boolean Protected PlanarMaskBaseTool  
endDynamics(): void PlanarMaskBaseTool Call to terminate dynamics mode.
exitTool(): Promise<void> PlanarMaskBaseTool  
filterHit(hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> PlanarMaskBaseTool  
getCurrentButtonEvent(ev: BeButtonEvent): void PlanarMaskBaseTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps PlanarMaskBaseTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string PlanarMaskBaseTool Returns the prompt based on the tool's current state.
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> PlanarMaskBaseTool Override to return the property that is disabled/enabled if the supplied property is a lock property.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> PlanarMaskBaseTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void PlanarMaskBaseTool Helper method for tools that need to locate existing elements.
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void PlanarMaskBaseTool Helper method to establish initial values for tool setting properties from saved settings.
isCompatibleViewport(vp: undefined | Viewport, isSelectedViewChange: boolean): boolean PlanarMaskBaseTool Determine whether the supplied Viewport is compatible with this tool.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean PlanarMaskBaseTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onCleanup(): Promise<void> PlanarMaskBaseTool  
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool  
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void PlanarMaskBaseTool Called to allow Tool to display dynamic elements.
onInstall(): Promise<boolean> PlanarMaskBaseTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> PlanarMaskBaseTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> PlanarMaskBaseTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the button is released after onMouseStartDrag.
onMouseMotion(_ev: BeButtonEvent): Promise<void> PlanarMaskBaseTool Invoked when the cursor is moving
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the mouse wheel moves.
onPostInstall(): Promise<void> PlanarMaskBaseTool  
onRedoPreviousStep(): Promise<boolean> PlanarMaskBaseTool Called to reinstate to a previous tool state (ex.
onReinitialize(): Promise<void> PlanarMaskBaseTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the reset button is pressed.
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> PlanarMaskBaseTool Invoked when the reset button is released.
onRestartTool(): Promise<void> PlanarMaskBaseTool  
onSelectedViewportChanged(_previous: undefined | Viewport, current: undefined | Viewport): Promise<void> PlanarMaskBaseTool Called when active view changes.
onSuspend(): Promise<void> PlanarMaskBaseTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> PlanarMaskBaseTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> PlanarMaskBaseTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> PlanarMaskBaseTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> PlanarMaskBaseTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> PlanarMaskBaseTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> PlanarMaskBaseTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> PlanarMaskBaseTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUndoPreviousStep(): Promise<boolean> PlanarMaskBaseTool Called to reverse to a previous tool state (ex.
onUnsuspend(): Promise<void> PlanarMaskBaseTool  
parseAndRun(...args: string[]): Promise<boolean> PlanarMaskBaseTool  
reloadToolSettingsProperties(): void PlanarMaskBaseTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean PlanarMaskBaseTool  
run(..._args: any[]): Promise<boolean> PlanarMaskBaseTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> PlanarMaskBaseTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
setRealityModelMask(vp: ScreenViewport, mask: PlanarClipMaskSettings): void Protected PlanarMaskBaseTool  
supplyToolSettingsProperties(): undefined | DialogItem[] PlanarMaskBaseTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void PlanarMaskBaseTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean PlanarMaskBaseTool Called to support operations on pickable decorations, like snapping.
register(namespace?: string): void Static PlanarMaskBaseTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor StaticReadOnly number The maximum number of arguments allowed by MaskBackgroundMapByModelTool.parseAndRun, or undefined if there is no maximum.  
minArgs Accessor StaticReadOnly number The minimum number of arguments allowed by MaskBackgroundMapByModelTool.parseAndRun.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_acceptedElementIds ProtectedReadonly Set<string> PlanarMaskBaseTool  
_acceptedModelIds ProtectedReadonly Set<string> PlanarMaskBaseTool  
_acceptedSubCategoryIds ProtectedReadonly Set<string> PlanarMaskBaseTool  
_invert Protected boolean PlanarMaskBaseTool  
_targetMaskModel Protected string | ContextRealityModelState PlanarMaskBaseTool  
_transparency Protected number PlanarMaskBaseTool  
_useSelection Protected boolean PlanarMaskBaseTool  
briefcase Accessor ReadOnly undefined | BriefcaseConnection PlanarMaskBaseTool Get the briefcase on which this tool operates, if the tool has successfully installed and the target PlanarMaskBaseTool.iModel is a briefcase.
description Accessor ReadOnly string PlanarMaskBaseTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string PlanarMaskBaseTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PlanarMaskBaseTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string PlanarMaskBaseTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string PlanarMaskBaseTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string PlanarMaskBaseTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
PlanarMaskBaseTool.keyin is returned.
hidden Static boolean PlanarMaskBaseTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor ReadOnly string PlanarMaskBaseTool Get the iconSpec from this Tool's class.
iconSpec Static string PlanarMaskBaseTool The icon for this Tool.
iModel Accessor ReadOnly IModelConnection PlanarMaskBaseTool Get the iModel on which this tool operates.
isControlDown Accessor ReadOnly boolean PlanarMaskBaseTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor ReadOnly boolean PlanarMaskBaseTool Call to find out if dynamics are currently active.
keyin Accessor ReadOnly string PlanarMaskBaseTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string PlanarMaskBaseTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static string PlanarMaskBaseTool The namespace that provides localized strings for this Tool.
receivedDownEvent boolean PlanarMaskBaseTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked boolean PlanarMaskBaseTool  
targetModelId Accessor undefined | string PlanarMaskBaseTool  
targetView undefined | Viewport PlanarMaskBaseTool The viewport within which the tool operates.
toolId Accessor ReadOnly string PlanarMaskBaseTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 16 April, 2024