FrontstageLaunchBackstageItemProps Interface

Deprecated  in 3.0. Use BackstageStageLauncher instead.

Properties for a FrontstageLaunchBackstageItem component

Extends

Inherited methods

Name Inherited from Description
stateFunc(state: Readonly<BackstageItemState>): BackstageItemState Optional BackstageItemProps optional function to set state of backstage item

Properties

Name Type Description
frontstageId string id of the frontstage  

Inherited properties

Name Type Inherited from Description
className undefined | string BackstageItemProps Custom CSS class name
description string | StringGetter BackstageItemProps if set, it is used to explicitly set the description shown by a component.
descriptionKey undefined | string BackstageItemProps if set, it is used to define a key that is used to look up a localized string.
iconSpec undefined | IconSpec BackstageItemProps CSS class name or SvgSprite/SvgPath for icon.
isActive undefined | boolean BackstageItemProps if set, component will be shown with as the active item - defaults to false
isEnabled undefined | boolean BackstageItemProps if set, component will be enabled - defaults to true
itemId undefined | string BackstageItemProps Optional unique identifier for item.
label string | StringGetter BackstageItemProps if set, it is used to explicitly set the label shown by a component.
labelKey undefined | string BackstageItemProps if set, it is used to define a key that is used to look up a localized string.
stateSyncIds undefined | string[] BackstageItemProps optional SyncUi event ids that will trigger the state function to run.
style undefined | CSSProperties BackstageItemProps Custom CSS style properties
tooltip string | StringGetter BackstageItemProps used to explicitly set the tooltip shown by a component.
tooltipKey undefined | string BackstageItemProps if set, it is used to define a key that is used to look up a localized string.

Defined in

Last Updated: 20 June, 2023