GroupItemDef Class

An Item that opens a group of items.

Extends

Methods

Name Description
constructor(groupItemProps: GroupItemProps, onItemExecuted?: OnItemExecutedFunc): GroupItemDef    
execute(): void Called when the action button is invoked by a click or touch  
getItemById(id: string): undefined | ItemDefBase    
getItemByIndex(index: number): undefined | ItemDefBase    
resolveItems(force?: boolean): void    
setPanelLabel(v: string | ConditionalStringValue | StringGetter): void Set the panelLabel.  
toolbarReactNode(index?: number): ReactNode   Deprecated  

Inherited methods

Name Inherited from Description
getDimension(orientation: Orientation): number ActionButtonItemDef Determines the dimension in a given orientation
handleSizeKnown(size: SizeProps): void ActionButtonItemDef Called when the size of the action button is initialized and the size is known
setDescription(v: string | ConditionalStringValue | StringGetter): void ActionButtonItemDef Set the description.
setLabel(v: string | ConditionalStringValue | StringGetter): void ActionButtonItemDef Set the label.
setTooltip(v: string | ConditionalStringValue | StringGetter): void ActionButtonItemDef Set the tooltip.
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static ActionButtonItemDef  

Properties

Name Type Description
defaultActiveItemId undefined | string    
direction Direction   Deprecated  
directionExplicit boolean   Deprecated  
groupId string    
groupIdPrefix Static string    
id Accessor ReadOnly string    
itemCount Accessor ReadOnly number    
items AnyItemDef[]    
itemsInColumn number    
panelLabel Accessor ReadOnly string Get the panelLabel string  

Inherited properties

Name Type Inherited from Description
_commandHandler Protected undefined | CommandHandler ActionButtonItemDef Command Handler for the action button
applicationData undefined | any ActionButtonItemDef  
badgeType undefined | BadgeType ActionButtonItemDef  
defaultButtonSize Static number ActionButtonItemDef The default button size for all action buttons
description Accessor ReadOnly string ActionButtonItemDef Get the description string
iconElement undefined | ReactNode ActionButtonItemDef  
iconSpec undefined | IconSpec ActionButtonItemDef  
isActive Accessor boolean ActionButtonItemDef  
isDisabled boolean | ConditionalBooleanValue ActionButtonItemDef  
isEnabled boolean ActionButtonItemDef  
isHidden boolean | ConditionalBooleanValue ActionButtonItemDef  
isPressed boolean ActionButtonItemDef  
isVisible boolean ActionButtonItemDef  
label Accessor ReadOnly string ActionButtonItemDef Get the label string
parameters undefined | any ActionButtonItemDef Parameters passed to the Command Handler
rawLabel Accessor ReadOnly string | ConditionalStringValue | StringGetter ActionButtonItemDef Get the label string
size undefined | SizeProps ActionButtonItemDef Size of the action button, as set by handleSizeKnown
stateFunc undefined | (state: Readonly<BaseItemState>) => BaseItemState ActionButtonItemDef  
stateSyncIds string[] ActionButtonItemDef  
tooltip Accessor ReadOnly string ActionButtonItemDef Get the tooltip string
trayId Accessor ReadOnly undefined ActionButtonItemDef  

Defined in

Last Updated: 20 June, 2023