PopupManager Class

Popup Manager class

Methods

Name Description
constructor(): PopupManager    
addOrUpdatePopup(popupInfo: PopupInfo): void Static    
closeToolSettings(): boolean Static    
getPopupPosition(el: HTMLElement, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, size: SizeProps): Point Static    
hideCard(): boolean Static    
hideHTMLElement(): boolean Static    
hideInputEditor(): boolean Static    
hideKeyinPalette(): boolean Static    
hideToolbar(): boolean Static    
openToolSettings(dataProvider: DialogLayoutDataProvider, el: HTMLElement, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onCancel: OnCancelFunc, relativePosition: RelativePosition): boolean Static    
removePopup(id: string): boolean Static    
showCard(content: PopupContentType, title: undefined | string | PropertyRecord, toolbarProps: undefined | AbstractToolbarProps, el: HTMLElement, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: OnItemExecutedFunc, onCancel: OnCancelFunc, relativePosition: RelativePosition): boolean Static    
showHTMLElement(displayElement: HTMLElement, el: HTMLElement, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onCancel: OnCancelFunc, relativePosition: RelativePosition): boolean Static    
showInputEditor(el: HTMLElement, pt: Readonly<WritableXAndY>, value: Value, propertyDescription: PropertyDescription, onCommit: OnValueCommitFunc, onCancel: OnCancelFunc): boolean Static    
showKeyinPalette(keyins: KeyinEntry[], el: HTMLElement, onItemExecuted?: OnItemExecutedFunc, onCancel?: OnCancelFunc): boolean Static    
showToolbar(toolbarProps: AbstractToolbarProps, el: HTMLElement, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: OnItemExecutedFunc, onCancel: OnCancelFunc, relativePosition: RelativePosition): boolean Static    

Properties

Name Type Description
defaultOffset Accessor Static Readonly<WritableXAndY>    
onPopupsChangedEvent StaticReadonly PopupsChangedEvent    
popupCount Accessor StaticReadOnly number    
popups Accessor Static undefined    

Defined in

Last Updated: 20 June, 2023