Zone Class

Deprecated  in 3.6. Use WidgetConfig or StagePanelConfig instead.

Zone React component. A Zone is a standard area on the screen for users to read and interact with data applicable to the current task. Each Zone has a defined purpose.

Extends

Methods

Name Description
constructor(props: ZoneProps): Zone    
componentDidMount(): void    
componentWillUnmount(): void    
render(): ReactNode    
initializeZoneDef(zoneDef: ZoneDef, props: ZoneProps): void Static    

Defined in

Last Updated: 20 June, 2023