ZoneDef Class

Deprecated  in 3.6. Use StagePanelDef or WidgetDef instead.

A ZoneDef represents each zone within a Frontstage.

Extends

Methods

Name Description
constructor(): ZoneDef Constructor for ZoneDef.  

Inherited methods

Name Inherited from Description
addWidgetDef(widgetDef: WidgetDef): void WidgetHost Adds a WidgetDef to the list of Widgets.
findWidgetDef(id: string): undefined | WidgetDef WidgetHost Finds a WidgetDef with a given Id.
getSingleWidgetDef(): undefined | WidgetDef WidgetHost If there is only one Widget in the Panel, gets the single WidgetDef.

Properties

Name Type Description
allowsMerging Accessor ReadOnly boolean Indicates if other Zones may be merged with this Zone.  
applicationData Accessor ReadOnly any Any application data to attach to this Zone.  
initialWidth Accessor ReadOnly undefined | number Initial zone width.  
isStatusBar Accessor ReadOnly boolean Determines if this Zone is for the Status Bar.  
isToolSettings Accessor ReadOnly boolean Determines if this Zone is for Tool Settings.  
mergeWithZone Accessor ReadOnly undefined | ZoneLocation Indicates with which other zone to merge.  
shouldFillZone Accessor ReadOnly boolean Determines if the Zone should fill the available space.  
zoneState Accessor ReadOnly ZoneState Zone state.  

Inherited properties

Name Type Inherited from Description
widgetCount Accessor ReadOnly number WidgetHost Gets the number of Widgets.
widgetDefs Accessor ReadOnly undefined WidgetHost Gets the list of Widgets.

Defined in

Last Updated: 20 June, 2023