GeographicTilingScheme Class

A MapTilingScheme using a simple geographic projection by which longitude and latitude are mapped directly to X and Y. This projection is commonly known as "geographic", "equirectangular", "equidistant cylindrical", or "plate carrée".

Extends

Methods

Name Description
constructor(numberOfLevelZeroTilesX: number = 2, numberOfLevelZeroTilesY: number = 1, rowZeroAtNorthPole: boolean = false): GeographicTilingScheme    
latitudeToYFraction(latitude: number): number Implements MapTilingScheme.latitudeToYFraction.  
yFractionToLatitude(yFraction: number): number Implements MapTilingScheme.yFractionToLatitude.  

Inherited methods

Name Inherited from Description
cartographicToFraction(latitudeRadians: number, longitudeRadians: number, result: Point2d): Point2d MapTilingScheme Given a cartographic location on the surface of the Earth, convert it to fractional coordinates in the XY plane.
cartographicToTileXY(carto: Cartographic, level: number, result?: Point2d): Point2d MapTilingScheme Given a cartographic position, compute the corresponding position on the surface of the Earth as fractional distances along the
fractionToCartographic(xFraction: number, yFraction: number, result: Cartographic, height: number = 0): Cartographic MapTilingScheme Given fractional coordinates in the XY plane and an elevation, compute the corresponding cartographic position.
getNumberOfXTilesAtLevel(level: number): number MapTilingScheme The total number of tiles in the X direction at the specified level of detail.
getNumberOfYTilesAtLevel(level: number): number MapTilingScheme The total number of tiles in the Y direction at the specified level of detail.
longitudeToXFraction(longitude: number): number MapTilingScheme Convert a longitude in [-pi, pi] radisn to a fraction in [0, 1] along the X axis.
tileBordersNorthPole(row: number, level: number): boolean MapTilingScheme Returns true if the tile at the specified X coordinate and level is adjacent to the north pole.
tileBordersSouthPole(row: number, level: number): boolean MapTilingScheme Returns true if the tile at the specified X coordinate and level is adjacent to the south pole.
tileXToFraction(x: number, level: number): number MapTilingScheme Given the X component and level of a QuadId, convert it to a fractional distance along the X axis.
tileXToLongitude(x: number, level: number): number MapTilingScheme Given the X component and level of a QuadId, compute its longitude in [-pi, pi] radians.
tileXYToCartographic(x: number, y: number, level: number, result: Cartographic, height: number = 0): Cartographic MapTilingScheme Given the components of a QuadId and an elevation, compute the corresponding Cartographic position.
tileXYToFraction(x: number, y: number, level: number, result?: Point2d): Point2d MapTilingScheme Given the components of a QuadId, compute its fractional coordinates in the XY plane.
tileXYToRectangle(x: number, y: number, level: number, result?: MapCartoRectangle): MapCartoRectangle MapTilingScheme Given the components of a QuadId, compute the corresponding region of the Earth's surface.
tileYToFraction(y: number, level: number): number MapTilingScheme Given the Y component and level of a QuadId, convert it to a fractional distance along the Y axis.
tileYToLatitude(y: number, level: number): number MapTilingScheme Given the Y component and level of a QuadId, compute its latitude in [-pi/2, pi/2] radians.
xFractionToLongitude(xFraction: number): number MapTilingScheme Convert a fraction in [0, 1] along the X axis into a longitude in [-pi, pi] radians.
xFractionToTileX(xFraction: number, level: number): number MapTilingScheme Given a fractional distance along the X axis and a level of the quad tree, compute the X component of the corresponding QuadId.
yFractionToTileY(yFraction: number, level: number): number MapTilingScheme Given a fractional distance along the Y axis and a level of the quad tree, compute the Y component of the corresponding QuadId.

Inherited properties

Name Type Inherited from Description
numberOfLevelZeroTilesX Readonly number MapTilingScheme The number of tiles in the X direction at level 0 of the quad tree.
numberOfLevelZeroTilesY Readonly number MapTilingScheme The number of tiles in the Y direction at level 0 of the quad tree.
rowZeroAtNorthPole Readonly boolean MapTilingScheme If true, the fractional Y coordinate 0 corresponds to the north pole and 1 to the south pole; otherwise,

Defined in

Last Updated: 15 March, 2024