DisplayStyle3dSettings Class

Provides access to the settings defined by a DisplayStyle3d or DisplayStyle3dState, and ensures that the style's JSON properties are kept in sync.

Extends

Methods

Name Description
constructor(jsonProperties: { styles?: DisplayStyle3dSettingsProps }, options?: DisplayStyleSettingsOptions): DisplayStyle3dSettings    
applyOverrides(overrides: DisplayStyle3dSettingsProps): void See DisplayStyleSettings.applyOverrides.  
clearSunTime(): void Clear the solar time point stored in this.lights.solarLight.  
getPlanProjectionSettings(modelId: string): undefined | PlanProjectionSettings Get the plan projection settings associated with the specified model, if defined.  
is3d(): this is DisplayStyle3dSettings Returns true if this is a DisplayStyle3dSettings.  
setPlanProjectionSettings(modelId: string, settings: undefined | PlanProjectionSettings): void Set or clear the plan projection settings associated with the specified model.  
setSunTime(timePoint: number, location: Cartographic | IModel): void Adjust the solar light direction based on a date and time at a geographic location.  
toJSON(): DisplayStyle3dSettingsProps Convert these settings to their JSON representation.  
toOverrides(options?: DisplayStyleOverridesOptions): DisplayStyle3dSettingsProps See DisplayStyleSettings.toOverrides.  
toggleAtmosphere(display?: boolean): void Toggle display of the DisplayStyle3dSettings.environment's DisplayStyle3dSettings.Atmosphere.  
toggleGroundPlane(display?: boolean): void Toggle display of the DisplayStyle3dSettings.environment's GroundPlane.  
toggleSkyBox(display?: boolean): void Toggle display of the DisplayStyle3dSettings.environment's SkyBox.  

Inherited methods

Name Inherited from Description
addExcludedElements(id: string | Iterable<string>): void DisplayStyleSettings Add one or more elements to the set of elements not to be displayed.
clearExcludedElements(): void DisplayStyleSettings Remove all elements from the set of elements not to be displayed.
dropExcludedElement(id: string): void DisplayStyleSettings Remove an element from the set of elements not to be displayed.
dropExcludedElements(id: string | Iterable<string>): void DisplayStyleSettings Remove one or more elements from the set of elements not to be displayed.
dropModelAppearanceOverride(id: string): void DisplayStyleSettings Remove any appearance overrides applied to a Model by this style.
dropSubCategoryOverride(id: string): void DisplayStyleSettings Remove any SubCategoryOverride applied to a SubCategoryAppearance by this style.
getModelAppearanceOverride(id: string): undefined | FeatureAppearance DisplayStyleSettings Obtain the override applied to a Model by this style.
getRealityModelDisplaySettings(modelId: string): undefined | RealityModelDisplaySettings DisplayStyleSettings Get any settings that override how the reality model with the specified Id is displayed.
getSubCategoryOverride(id: string): undefined | SubCategoryOverride DisplayStyleSettings Obtain the override applied to a SubCategoryAppearance by this style.
overrideModelAppearance(modelId: string, ovr: FeatureAppearance): void DisplayStyleSettings Customize the way a Model is drawn by this display style.
overrideSubCategory(id: string, ovr: SubCategoryOverride): void DisplayStyleSettings Customize the way geometry belonging to a SubCategory is drawn by this display style.
setRealityModelDisplaySettings(modelId: string, settings: undefined | RealityModelDisplaySettings): void DisplayStyleSettings Change the settings that control how the reality model with the specified Id is displayed.

Properties

Name Type Description
ambientOcclusionSettings Accessor AmbientOcclusion.Settings The settings that control how ambient occlusion is displayed.  
environment Accessor Environment Controls the display of a SkyBox, GroundPlane, and DisplayStyle3dSettings.Atmosphere.  
hiddenLineSettings Accessor HiddenLine.Settings The settings that control how visible and hidden edges are displayed.  
lights Accessor LightSettings    
planProjectionSettings Accessor ReadOnly undefined | Iterable<[string, PlanProjectionSettings]> An iterator over all of the defined plan projection settings.  
solarShadows Accessor SolarShadowSettings The settings that control how solar shadows are displayed.  
sunTime Accessor ReadOnly undefined | number The time point from which the solar light direction was derived, in UNIX milliseconds.  
thematic Accessor ThematicDisplay The settings that control thematic display.  

Inherited properties

Name Type Inherited from Description
_json ProtectedReadonly DisplayStyleSettingsProps DisplayStyleSettings  
analysisFraction Accessor number DisplayStyleSettings A floating point value in [0..1] indicating the current point in animation of the DisplayStyleSettings.analysisStyle, where 0 corresponds to the beginning of
the animation and 1 to the end. Default: 0.0.
analysisStyle Accessor undefined | AnalysisStyle DisplayStyleSettings Settings controlling the display of analytical models.
backgroundColor Accessor ColorDef DisplayStyleSettings The color displayed in the view background - by default, ColorDef.black.
backgroundMap Accessor BackgroundMapSettings DisplayStyleSettings Settings controlling display of the background map within views of geolocated models.
clipStyle Accessor ClipStyle DisplayStyleSettings The style applied to the view's ClipVector.
contextRealityModels Accessor ReadOnly ContextRealityModels DisplayStyleSettings Reality models to be displayed in the view.
excludedElementIds Accessor ReadOnly OrderedId64Iterable DisplayStyleSettings The set of elements that will not be drawn by this display style.
hasModelAppearanceOverride Accessor ReadOnly boolean DisplayStyleSettings Returns true if model appearance overrides are defined by this style.
hasSubCategoryOverride Accessor ReadOnly boolean DisplayStyleSettings Returns true if an SubCategoryOverrides are defined by this style.
mapImagery Accessor MapImagerySettings DisplayStyleSettings Settings defining the map imagery layers to be displayed within the view.
modelAppearanceOverrides Accessor ReadOnly Map<string, FeatureAppearance> DisplayStyleSettings The overrides applied by this style.
monochromeColor Accessor ColorDef DisplayStyleSettings The color used to draw geometry when ViewFlags.monochrome is enabled - by default, ColorDef.white.
The monochrome color is applied to all surfaces and linear geometry, but only applied to the edges of surfaces in RenderMode.Wireframe.
monochromeMode Accessor MonochromeMode DisplayStyleSettings The style in which DisplayStyleSettings.monochromeColor is applied when ViewFlags.monochrome is enabled - by default, MonochromeMode.Scaled.
onAmbientOcclusionSettingsChanged Readonly BeEvent<(newSettings: AmbientOcclusion.Settings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.ambientOcclusionSettings property.
onAnalysisFractionChanged Readonly BeEvent<(newFraction: number) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.analysisFraction property.
onAnalysisStyleChanged Readonly BeEvent<(newStyle: undefined | Readonly<AnalysisStyle>) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.analysisStyle property.
onApplyOverrides Readonly BeEvent<(overrides: Readonly<DisplayStyleSettingsProps>) => void> DisplayStyleSettings Event raised by DisplayStyleSettings.applyOverrides just before the overrides are applied.
onBackgroundColorChanged Readonly BeEvent<(newColor: ColorDef) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.backgroundColor property.
onBackgroundMapChanged Readonly BeEvent<(newMap: BackgroundMapSettings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.backgroundMap property.
onClipStyleChanged Readonly BeEvent<(newStyle: ClipStyle) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.clipStyle property.
onEnvironmentChanged Readonly BeEvent<(newEnv: Readonly<Environment>) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.environment property.
onExcludedElementsChanged Readonly BeEvent<() => void> DisplayStyleSettings Event raised when the contents of DisplayStyleSettings.excludedElementIds changes.
onHiddenLineSettingsChanged Readonly BeEvent<(newSettings: HiddenLine.Settings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.hiddenLineSettings property.
onLightsChanged Readonly BeEvent<(newLights: LightSettings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.lights property.
onMapImageryChanged Readonly BeEvent<(newImagery: Readonly<MapImagerySettings>) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.mapImagery property.
onModelAppearanceOverrideChanged Readonly BeEvent<(modelId: string, newAppearance: undefined | FeatureAppearance) => void> DisplayStyleSettings Event raised just before changing the appearance override for a model.
onMonochromeColorChanged Readonly BeEvent<(newColor: ColorDef) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.monochromeColor property.
onMonochromeModeChanged Readonly BeEvent<(newMode: MonochromeMode) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.monochromeMode property.
onOverridesApplied Readonly BeEvent<(overrides: Readonly<DisplayStyleSettingsProps>) => void> DisplayStyleSettings Event raised by DisplayStyleSettings.applyOverrides after the overrides are applied.
onPlanarClipMaskChanged Readonly BeEvent<(modelId: string, newSettings: undefined | PlanarClipMaskSettings) => void> DisplayStyleSettings Event raised just before adding or removing an entry from DisplayStyleSettings.planarClipMasks.
onPlanProjectionSettingsChanged Readonly BeEvent<(modelId: string, newSettings: undefined | PlanProjectionSettings) => void> DisplayStyleSettings Event raised just before changing the plan projection settings for a model.
onRealityModelDisplaySettingsChanged Readonly BeEvent<(modelId: string, newSettings: undefined | RealityModelDisplaySettings) => void> DisplayStyleSettings Event raised just before DisplayStyleSettings.setRealityModelDisplaySettings changes the display settings for a reality model.
onRenderTimelineChanged Readonly BeEvent<(newRenderTimeline: undefined | string) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.renderTimeline property.
onScheduleScriptPropsChanged Readonly BeEvent<(newProps: undefined | ) => void> DisplayStyleSettings Event raised just prior to assignment to the scheduleScriptProps property.
onSolarShadowsChanged Readonly BeEvent<(newSettings: SolarShadowSettings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.solarShadows property.
onSubCategoryOverridesChanged Readonly BeEvent<(subCategoryId: string, newOverrides: undefined | SubCategoryOverride) => void> DisplayStyleSettings Event raised when the SubCategoryOverrides change.
onThematicChanged Readonly BeEvent<(newThematic: ThematicDisplay) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyle3dSettings.thematic property.
onTimePointChanged Readonly BeEvent<(newTimePoint: undefined | number) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.timePoint property.
onViewFlagsChanged Readonly BeEvent<(newFlags: Readonly<ViewFlags>) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.viewFlags property.
onWhiteOnWhiteReversalChanged Readonly BeEvent<(newSettings: WhiteOnWhiteReversalSettings) => void> DisplayStyleSettings Event raised just prior to assignment to the DisplayStyleSettings.whiteOnWhiteReversal property.
planarClipMasks Accessor ReadOnly Map<string, PlanarClipMaskSettings> DisplayStyleSettings Planar clip masks to be applied to persistent reality models (See: SpatialModelState.isRealityModel.
The key for each entry is the Id of the model to which the mask settings apply.
renderTimeline Accessor undefined | string DisplayStyleSettings The Id of a RenderTimeline element containing a RenderSchedule.Script used to animate the view.
If DisplayStyleSettings.scheduleScriptProps is defined, it takes precedence over the script supplied by the RenderTimeline.
scheduleScriptProps Accessor undefined | RenderSchedule.ScriptProps DisplayStyleSettings JSON representation of a RenderSchedule.Script embedded in the display style describing how to animate the contents of the view over time.
This script, if present, takes precedence over a script supplied by DisplayStyleSettings.renderTimeline.
subCategoryOverrides Accessor ReadOnly Map<string, SubCategoryOverride> DisplayStyleSettings The overrides applied by this style.
timePoint Accessor undefined | number DisplayStyleSettings The point in time currently reflected by the view, expressed in seconds in the Unix epoch.
This identifies a point on the timeline of the style's RenderSchedule.Script, if any; it may also affect display of four-dimensional reality models.
viewFlags Accessor ViewFlags DisplayStyleSettings Flags controlling various aspects of the display style.
whiteOnWhiteReversal Accessor WhiteOnWhiteReversalSettings DisplayStyleSettings Settings controlling how white-on-white reversal is applied when ViewFlags.whiteOnWhiteReversal is enabled.

Defined in

Last Updated: 16 April, 2024