Polyface

A Polyface is a mesh structure with arrays of points that are shared among multiple incident facets.

Classes

Name Description  
AuxChannel Represents a single PolyfaceAuxData channel.  
AuxChannelData Represents the AuxChannel data at a single input value.  
ClippedPolyfaceBuilders A pair of PolyfaceBuilder objects, for use by clippers that emit inside and outside parts.  
FacetFaceData Data for a face in a polyface containing facets.  
FacetOrientationFixup  
IndexedEdgeMatcher An IndexedEdgeMatcher carries an array (edges) of edges start & end indices for sorting and subsequent analyses (such as testing for closed mesh)  
IndexedPolyface An IndexedPolyface is a set of facets which can have normal, param, and color arrays with independent point, normal, param, and color indices.  
IndexedPolyfaceSubsetVisitor An IndexedPolyfaceSubsetVisitor is an IndexedPolyfaceVisitor which only visits a subset of facets in the polyface.  
IndexedPolyfaceVisitor An IndexedPolyfaceVisitor is an iterator-like object that "visits" facets of a mesh.  
Polyface A Polyface is n abstract mesh structure (of unspecified implementation) that provides a PolyfaceVisitor  
PolyfaceAuxData The PolyfaceAuxData structure contains one or more analytical data channels for each vertex of a Polyface, allowing the polyface to be styled  
PolyfaceBuilder * Simple construction for strongly typed GeometryQuery objects:  
PolyfaceClip PolyfaceClip is a static class gathering operations using Polyfaces and clippers.  
PolyfaceData PolyfaceData carries data arrays for point, normal, param, color and their indices.  
PolyfaceQuery PolyfaceQuery is a static class whose methods implement queries on a polyface or polyface visitor provided as a parameter to each method.  
SortableEdge * For boundary sorting, an edge is a (packed!) Float64Array.  
SweepLineStringToFacetContext  
TaggedNumericData Structure with 2 integer tags and optional arrays of integers, doubles, points, vectors, and geometry.  

Enumerations

Name Description  
AuxChannelDataType The types of data that can be represented by an AuxChannelData.  
DuplicateFacetClusterSelector Enumeration of cases for retaining facets among duplicates  

Interfaces

Name Description  
FacetProjectedVolumeSums Structure to return multiple results from volume between facets and plane  
PolyfaceVisitor A PolyfaceVisitor manages data while walking through facets.  

Namespaces

Name Description  
TaggedNumericConstants TaggedNumericConstants defines enums with constant values for use in tags of TaggedNumericData  

Type Aliases

Name Description  
AnnounceDrapePanel  
SortableEdgeCluster  

Last Updated: 29 November, 2022