Views

Classes for working with Views

Classes

Name Description  
AuxCoordSystem2dState The state of an AuxCoordSystem2d element in the frontend  
AuxCoordSystem3dState The state of an AuxCoordSystem3d element in the frontend  
AuxCoordSystemSpatialState The state of an AuxCoordSystemSpatial element in the frontend  
AuxCoordSystemState The state of an AuxCoordSystem element in the frontend  
CategorySelectorState A set of Categories to be displayed in a ViewState.  
ChangeFlags Describes which aspects of a Viewport have changed.  
Cluster A cluster of one or more Markers that overlap one another in the view.  
ContextRealityModelState A ContextRealityModel attached to a DisplayStyleState supplying a TileTreeReference used to draw the  
DisplayStyle2dState A display style that can be applied to 2d views.  
DisplayStyle3dState A DisplayStyleState that can be applied to spatial views.  
DisplayStyleState A DisplayStyle defines the parameters for 'styling' the contents of a ViewState.  
DrawingViewState A view of a DrawingModel  
Environment Describes the SkyBox and Environment.GroundPlane associated with a DisplayStyle3dState.  
FrustumAnimator Animates the transition of a Viewport from one Frustum to another.  
GlobeAnimator Animates the transition of a Viewport to view a location on the Earth.  
IconSprites Icon sprites are loaded from .png files in the assets directory of imodeljs-native.  
MarginPercent Margins for white space to be left around view volumes for ViewState.lookAtVolume.  
Marker A Marker is a CanvasDecoration, whose position follows a fixed location in world space.  
MarkerSet A set of Markers that are logically related, such that they cluster when they overlap one another in screen space.  
ModelSelectorState The state of a ModelSelector.  
OffScreenViewport A viewport that draws to an offscreen buffer instead of to the screen.  
OrthographicViewState Defines a spatial view that displays geometry on the image plane using a parallel orthographic projection.  
PlanarClipMaskState The State of Planar Clip Mask applied to a reality model or background map. Beta
ScreenViewport An interactive Viewport that exists within an HTMLDivElement.  
SheetViewState A view of a SheetModel.  
SkyBox The SkyBox is part of an Environment drawn in the background of spatial views to provide context.  
SkyCube A SkyBox drawn as a cube with an image mapped to each of its interior faces.  
SkyGradient A SkyBox drawn as a sphere with a gradient mapped to its interior surface.  
SkySphere A SkyBox drawn as a sphere with an image mapped to its interior surface.  
SpatialViewState Defines a view of one or more SpatialModels.  
Sprite Sprites are small raster images that are drawn on top of Viewports by a ViewDecoration.  
SpriteLocation A Sprite location.  
StandardView Supplies access to a set of commonly-used view rotations.  
TwoWayViewportSync Forms a bidirectional connection between two Viewports such that the Frustums of both Viewports are synchronized.  
ViewCreator2d API for creating a ViewState2d for a 2D model (GeometricModel2dState).  
ViewCreator3d API for creating a 3D default ViewState3d for an iModel.  
ViewingSpace Describes a Viewport's viewing volume, plus its size on the screen.  
ViewManager The ViewManager holds the list of opened views, plus the selected view.  
Viewport A Viewport renders the contents of one or more GeometricModels onto an HTMLCanvasElement.  
ViewPose The "pose" for a view.  
ViewRect A rectangle in unsigned integer view coordinates with (0,0) corresponding to the top-left corner of the view.  
ViewState The front-end state of a ViewDefinition element.  
ViewState2d Defines the state of a view of a single 2d model.  
ViewState3d Defines the state of a view of 3d models.  

Enumerations

Name Description  
ACSDisplayOptions  
ACSType  
CoordSystem Coordinate system types  
DepthPointSource Source of depth point returned by Viewport.pickDepthPoint.  
StandardViewId Describes a set of commonly-used view rotations.  
ViewStatus Describes the result of a viewing operation such as those exposed by ViewState and Viewport.  
ViewUndoEvent Describes an undo or redo event for a Viewport.  

Global Functions

Name Description  
calculateEcefToDbTransformAtLocation Calculate the ECEF to database (IModel) coordinate transform at a provided location, using the GCS of the iModel.  
queryRealityData Query for reality data associated with an iTwin context.  
queryTerrainElevationOffset Queries the actual elevation of a cartographic point on the globe (using Bing elevation services)  

Interfaces

Name Description  
Animator An object to animate a transition of a Viewport.  
ChangeViewedModel2dOptions Options for changing the viewed Model of a 2d view via Viewport.changeViewedModel2d  
Decorator Interface for drawing Decorations into, or on top of, the active ScreenViewports managed by ViewManager.  
DepthPointOptions Options to control behavior of Viewport.pickDepthPoint.  
DepthRangeNpc The minimum and maximum values for the z-depth of a rectangle of screen space.  
ExtentLimits Describes the largest and smallest values allowed for the extents of a ViewState.  
FeatureOverrideProvider An object that customizes the appearance of Features within a Viewport.  
GetPixelDataWorldPointArgs Arguments to Viewport.getPixelDataWorldPoint.  
GlobalLocation Describes a location on the earth using cartographic data structures.  
GlobalLocationArea Describes a rectangular area of the earth using cartographic data structures.  
MapLayerOptions Options to be passed to the IModelApp on startup which contain access keys for various layer formats Beta
ModelDisplayTransformProvider Interface adopted by an object that wants to apply a per-model display transform. Beta
OffScreenViewportOptions Options supplied when creating an OffScreenViewport.  
OsmBuildingDisplayOptions Options controlling display of OpenStreetMap Buildings.  
RealityDataQueryCriteria Criteria used to query for reality data associated with an iTwin context.  
SelectedViewportChangedArgs Argument for ViewManager.onSelectedViewportChanged  
TiledGraphicsProvider Provides a way for applications to inject additional non-decorative graphics into a Viewport by supplying one or more TileTreeReferences capable of loading and drawing the graphics.  
ViewAnimationOptions Options that control how an Viewport animation behaves.  
ViewChangeOptions Options that control how operations that change a viewport behave.  
ViewCreator2dOptions Options for creating a ViewState2d via ViewCreator2d.  
ViewCreator3dOptions Options for creating a ViewState3d via ViewCreator3d.  
ViewportDecorator Interface for drawing Decorations into, or on top of, a ScreenViewport.  
ZoomToOptions Options to allow changing the view rotation with zoomTo methods.  

Namespaces

Name Description  
Frustum2d Constants and functions for working with two-dimensions Frustums.  
PerModelCategoryVisibility Per-model category visibility permits the visibility of categories within a Viewport displaying a SpatialViewState to be overridden in  
SkyBox The SkyBox is part of an Environment drawn in the background of spatial views to provide context.  
TiledGraphicsProvider  

Type Aliases

Name Description  
MarkerFillStyle  
MarkerImage The types that may be used for Markers  
MarkerTextAlign  
MarkerTextBaseline  
OnFlashedIdChangedEventArgs Payload for the Viewport.onFlashedIdChanged event indicating Ids of the currently- and/or previously-flashed objects.  

Last Updated: 29 November, 2022