presentation-components

Classes

Name Description
ContentDataProvider Base class for all presentation-driven content providers.
DataProvidersFactory A factory class than can be used to create presentation data providers targeted towards
FavoritePropertiesDataFilterer IPropertyDataFilterer implementation which filters favorite properties Beta
FavoritePropertiesDataProvider Presentation Rules-driven element favorite properties data provider implementation.
InstanceKeyValueRenderer Property value renderer for instance keys. Beta
PresentationLabelsProvider Presentation Rules-driven labels provider implementation.
PresentationPropertyDataProvider Presentation Rules-driven property data provider implementation.
PresentationTableDataProvider Presentation Rules-driven table data provider.
PresentationTreeDataProvider Presentation Rules-driven tree data provider.
UnifiedSelectionTreeEventHandler Tree event handler that handles unified selection.

Constants

Name Description
DEFAULT_PROPERTY_GRID_RULESET Default presentation ruleset used by PresentationPropertyDataProvider.
TABLE_DATA_PROVIDER_DEFAULT_CACHED_PAGES_COUNT The default number of pages cached by PresentationTableDataProvider
TABLE_DATA_PROVIDER_DEFAULT_PAGE_SIZE The default number of rows in a single page requested by PresentationTableDataProvider

Enumerations

Name Description
PresentationComponentsLoggerCategory Logger categories used by this package

Global Functions

Name Description
DEPRECATED_controlledTreeWithFilteringSupport A HOC component that adds filtering functionality to the supplied Beta
DEPRECATED_controlledTreeWithVisibleNodes A HOC component that injects visible nodes into supplied tree component. Beta
DEPRECATED_treeWithFilteringSupport A HOC component that adds filtering functionality to the supplied Deprecated
DEPRECATED_treeWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied Deprecated
propertyGridWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied Deprecated
tableWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied
UnifiedSelectionContextProvider Unified Selection context provider. Beta
useControlledPresentationTreeFiltering A custom hook that creates filtered model source and node loader for supplied filter.
useControlledTreeFiltering A custom hook that creates filtered model source and node loader for supplied filter. Beta
usePresentationTreeNodeLoader Custom hooks which creates PagedTreeNodeLoader with PresentationTreeDataProvider using
usePropertyDataProviderWithUnifiedSelection A React hook that adds unified selection functionality to the provided data provider.
useRulesetRegistration Custom hook which registers supplied Ruleset on mount and removes on unmount.
useUnifiedSelectionContext Returns Unified Selection context provided by UnifiedSelectionContextProvider. Beta
useUnifiedSelectionTreeEventHandler A custom hook which creates and disposes UnifiedSelectionTreeEventHandler
viewWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied

Interfaces

Name Description
CacheInvalidationProps Properties for invalidating content cache.
ContentDataProviderProps Properties for creating a ContentDataProvider instance.
ControlledPresentationTreeFilteringProps Parameters for useControlledPresentationTreeFiltering hook
ControlledTreeWithFilteringSupportProps Props that are injected to the ControlledTreeWithFilteringSupport HOC component. Beta
ControlledTreeWithVisibleNodesProps Props that are injected to the ControlledTreeWithModelSource HOC component. Beta
DataProvidersFactoryProps Data structure holding initialization properties for DataProvidersFactory
DiagnosticsProps Settings for capturing diagnostics data.
FavoritePropertiesDataFiltererProps Props for FavoritePropertiesDataFilterer. Beta
FavoritePropertiesDataProviderProps Props for FavoritePropertiesDataProvider
IContentDataProvider Interface for all presentation-driven content providers.
IFavoritePropertiesDataProvider An data provider interface for returning favorite properties for the given elements
IFilteredPresentationTreeDataProvider Filtered presentation tree data provider.
IPresentationDataProvider Interface for a presentation data provider
IPresentationLabelsProvider Interface for presentation rules-driven labels provider.
IPresentationTreeDataProvider Presentation tree data provider.
IUnifiedSelectionComponent An interface for all unified selection components
PresentationLabelsProviderProps Properties for creating a LabelsProvider instance.
PresentationPropertyDataProviderProps Properties for creating a LabelsProvider instance.
PresentationTableDataProviderProps Initialization properties for PresentationTableDataProvider
PresentationTreeDataProviderDataSourceEntryPoints Definitions of methods used by PresentationTreeDataProvider to get nodes' data. Beta
PresentationTreeDataProviderProps Properties for creating a PresentationTreeDataProvider instance.
PresentationTreeNodeLoaderProps Properties for usePresentationTreeNodeLoader hook.
PropertyDataProviderWithUnifiedSelectionProps Props for the usePropertyDataProviderWithUnifiedSelection hook
PropertyGridWithUnifiedSelectionProps Props that are injected to the PropertyGridWithUnifiedSelection HOC component. Deprecated
TableWithUnifiedSelectionProps Props that are injected to the TableWithUnifiedSelection HOC component.
TreeWithFilteringSupportProps Props that are injected to the TreeWithFilteringSupport HOC component. Deprecated
TreeWithUnifiedSelectionProps Props that are injected to the TreeWithUnifiedSelection HOC component. Deprecated
UnifiedSelectionContext Interface for accessing and modifying Unified Selection within React components. Beta
UnifiedSelectionContextProviderProps Props for Unified Selection context provider. Beta
UnifiedSelectionTreeEventHandlerParams Data structure that describes parameters for UnifiedSelectionTreeEventHandler
UsePropertyDataProviderWithUnifiedSelectionResult usePropertyDataProviderWithUnifiedSelection return type.
ViewWithUnifiedSelectionProps Props that are injected to the ViewWithUnifiedSelection HOC component.

Namespaces

Name Description
CacheInvalidationProps

Type Aliases

Name Description
ControlledTreeFilteringProps Parameters for useControlledTreeFiltering hook Beta
IPresentationPropertyDataProvider Interface for presentation rules-driven property data provider.
IPresentationTableDataProvider Interface for presentation rules-driven table data provider.
UnifiedSelectionState

Last Updated: 29 November, 2022