Core

Common types used all across Presentation packages.

Classes

Name Description  
KeySet A class that holds multiple Key objects.  
PresentationError An error type thrown by Presentation APIs.  
RegisteredRuleset A ruleset that is registered in a ruleset manager.  
RulesetsFactory A factory class that can be used to create presentation rulesets targeted towards  

Constants

Name Description  
DEFAULT_KEYS_BATCH_SIZE Default (recommended) keyset batch size for cases when it needs to be sent  

Enumerations

Name Description  
LoggingNamespaces Enum of logging namespaces used by Presentation library. Deprecated
PresentationStatus Status codes used by Presentation APIs.  
PresentationUnitSystem Enumeration of unit systems that can be used when formatting values. Beta
RequestPriority Enumeration of standard request priorities.  
VariableValueTypes Possible variable value types  

Global Functions

Name Description  
getInstancesCount Get total number of instances included in the supplied key set.  

Interfaces

Name Description  
BooleanRulesetVariable Data structure for representing boolean ruleset variables.  
BooleanRulesetVariableJSON JSON representation of BooleanRulesetVariable.  
ClassInfo Information about an ECClass  
ClassInfoJSON A serialized version of ClassInfo  
CompressedClassInfoJSON A serialized and compressed version of ClassInfo  
ContentDescriptorRequestOptions Request type for content descriptor requests  
ContentRequestOptions Request type for content requests Deprecated
DisplayLabelRequestOptions Request type for label requests  
DisplayLabelsRequestOptions Request type for labels requests  
DistinctValuesRequestOptions Request type for distinct values' requests  
ElementPropertiesRequestOptions Request type for element properties requests. Beta
EnumerationChoice A single choice in enumeration  
EnumerationInfo Enumeration information  
ExtendedContentRequestOptions Request type for content requests  
ExtendedHierarchyRequestOptions Request type for hierarchy requests  
HierarchyCompareInfo Information about hierarchy modification / differences.  
HierarchyCompareInfoJSON JSON representation of HierarchyCompareInfo.  
HierarchyCompareOptions Data structure for comparing a hierarchy after ruleset or ruleset variable changes.  
HierarchyRequestOptions Base request type for hierarchy requests Deprecated
Id64RulesetVariable Data structure for representing ID ruleset variables.  
Id64RulesetVariableJSON JSON representation of Id64RulesetVariable.  
Id64sRulesetVariable Data structure for representing ID array ruleset variables.  
Id64sRulesetVariableJSON JSON representation of Id64sRulesetVariable.  
InstanceKey A key that uniquely identifies an instance in an iModel  
InstanceKeyJSON A serialized version of InstanceKey  
IntRulesetVariable Data structure for representing int ruleset variables.  
IntRulesetVariableJSON JSON representation of IntRulesetVariable.  
IntsRulesetVariable Data structure for representing int array ruleset variables.  
IntsRulesetVariableJSON JSON representation of IntsRulesetVariable.  
KeySetJSON A data structure of serialized KeySet  
KindOfQuantityInfo Kind of quantity information  
LabelRequestOptions Request type for label requests Deprecated
NodeDeletionInfo Information about node deletion.  
NodeDeletionInfoJSON JSON representation of NodeDeletionInfo.  
NodeInsertionInfo Information about node insertion.  
NodeInsertionInfoJSON JSON representation of NodeInsertionInfo.  
NodeUpdateInfo Information about node update.  
NodeUpdateInfoJSON JSON representation of NodeUpdateInfo.  
PagedResponse A structure for paged responses  
PageOptions Paging options  
PropertyInfo A structure that describes an ECProperty  
PropertyInfoJSON A serialized version of PropertyInfo  
RelatedClassInfo A structure that describes a related class and the properties of that relationship.  
RelatedClassInfoJSON A serialized version of RelatedClassInfo  
RequestOptions A generic request options type used for both hierarchy and content requests  
RequestOptionsWithRuleset Options for requests that require presentation ruleset.  
RulesetVariableBase Base data structure for representing ruleset variables.  
RulesetVariableBaseJSON JSON representation of RulesetVariableBase.  
SelectionScopeRequestOptions Request options used for selection scope related requests  
StringRulesetVariable Data structure for representing string ruleset variables.  
StringRulesetVariableJSON JSON representation of StringRulesetVariable.  
StrippedRelatedClassInfo Data structure that contains a subset of RelatedClassInfo required to  
ValuesDictionary A dictionary data structure.  

Namespaces

Name Description  
ClassInfo  
HierarchyCompareInfo  
InstanceKey  
Key  
PartialHierarchyModification  
PropertyInfo  
RelatedClassInfo  
RelationshipPath  
RulesetVariable  

Type Aliases

Name Description  
ClassId Type of an ECClass ID.  
ComputeDisplayValueCallback  
InstanceId Type of an ECInstance ID.  
Key A single key that identifies something in iModel.js application  
Keys A type for multiple keys that identify something in iModel.js application  
Omit Create a type with T properties excluding properties listed in K.  
Paged A wrapper type that injects PageOptions into supplied type  
PartialHierarchyModification Information about a hierarchy change: insertion, deletion or node update.  
PartialHierarchyModificationJSON JSON representation of PartialHierarchyModification.  
PresentationDataCompareOptions Data structure for comparing presentation data after ruleset or ruleset variable changes. Deprecated
PrimitivePropertyValue Value of a primitive property.  
RelationshipPath A structure that describes a related class path.  
RelationshipPathJSON Serialized RelationshipPath  
RulesetVariable Data structure for representing ruleset variables.  
RulesetVariableJSON JSON representation of RulesetVariable.  
StrippedRelationshipPath Data structure that contains a subset of RelationshipPath required to  
Subtract Create a type with T properties excluding all properties in type K.  
VariableValue Union of all supported variable value types  
VariableValueJSON JSON representation of VariableValue  

Last Updated: 29 November, 2022