Rendering

Classes for rendering the contents of views.

Classes

Name Description  
DecorateContext Provides context for a ViewportDecorator to add Decorations to be rendered within a Viewport.  
Decorations A set of RenderGraphics and CanvasDecorations produced by Tools and Decorators, used to decorate the contents of a Viewport.  
DynamicsContext Provides context for an InteractiveTool to display decorations representing its current state.  
EmphasizeElements An implementation of FeatureOverrideProvider for emphasizing selected elements through simple color/transparency appearance overrides.  
FlashSettings Settings that control how geometry is "flashed" when hovered over in a Viewport.  
GraphicBranch A node in a scene graph.  
GraphicBuilder Provides methods for constructing a RenderGraphic from geometric primitives.  
MeshParams Describes mesh geometry to be submitted to the rendering system.  
PolylineParams Describes a set of tesselated polylines.  
RenderClipVolume An opaque representation of a clip volume applied to geometry within a Viewport.  
RenderContext Provides context for producing RenderGraphics for drawing within a Viewport.  
RenderGraphic Abstract representation of an object which can be rendered by a RenderSystem.  
RenderGraphicOwner A graphic that owns another graphic.  
RenderSystem A RenderSystem provides access to resources used by the internal WebGL-based rendering system.  
Scene Holds a collection of objects comprising the scene to be drawn by a Viewport's.  
SceneContext Context used to create the scene to be drawn in a Viewport.  
VertexTableBuilder Builds a VertexTable from some data type supplying the vertex data.  

Enumerations

Name Description  
Child  
FeatureOverrideType Options for overriding element appearance. Deprecated
FlashMode As part of FlashSettings, describes how geometry is flashed.  
GraphicType Describes the type of a GraphicBuilder, which defines the coordinate system in which the builder's geometry is defined and  
UniformType The underlying data types that can be used for uniform variables in screen-space effect shaders.  
VaryingType The underlying data types that can be used for varying variables in screen-space effect shaders.  

Global Functions

Name Description  
canvasToImageBuffer Create an ImageBuffer in the specified format with the same dimensions and contents as a canvas.  
canvasToResizedCanvasWithBars Resize a canvas to a desired size.  
extractImageSourceDimensions Extract the dimensions of the jpeg or png data encoded in an ImageSource.  
getCenteredViewRect Determine the maximum ViewRect that can be fitted and centered in specified ViewRect given a required aspect ratio.  
getCompressedJpegFromCanvas Produce a jpeg compressed to no more than specified bytes and of no less than specified quality.  
getImageSourceFormatForMimeType Get the ImageSourceFormat corresponding to the mime type string, or undefined if the string does not identify a supported ImageSourceFormat.  
getImageSourceMimeType Get a string describing the mime type associated with an ImageSource format.  
imageBufferToBase64EncodedPng Converts the contents of an ImageBuffer to PNG format.  
imageBufferToCanvas Create a canvas element with the same dimensions and contents as an image buffer.  
imageBufferToPngDataUrl Produces a data url in "image/png" format from the contents of an ImageBuffer.  
imageElementFromImageSource Extract an html Image element from a binary jpeg or png.  
imageElementFromUrl Create an html Image element from a URL.  
openImageDataUrlInNewWindow Open an image specified as a data URL in a new window or tab. Beta
tesselatePolyline Strictly for tests.  
tryImageElementFromUrl Try to create an html Image element from a URL.  

Interfaces

Name Description  
BatchOptions Options used when constructing a Batch - that is, a RenderGraphic with an associated FeatureTable describing individual Features within the  
CanvasDecoration A Decoration that is drawn onto the  
EdgeParams Describes the edges of a mesh.  
GraphicArc A GraphicPrimitive representing a 3d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive.  
GraphicArc2d A GraphicPrimitive representing a 2d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive.  
GraphicBranchOptions Options passed to RenderSystem.createGraphicBranch.  
GraphicBuilderOptions Options for creating a GraphicBuilder used by functions like DecorateContext.createGraphic and RenderSystem.createGraphic.  
GraphicLineString A GraphicPrimitive representing a line string that can be supplied to GraphicBuilder.addPrimitive.  
GraphicLineString2d A GraphicPrimitive representing a 2d line string that can be supplied to GraphicBuilder.addPrimitive.  
GraphicLoop A GraphicPrimitive representing a 3d planar region that can be supplied to GraphicBuilder.addPrimitive.  
GraphicPath A GraphicPrimitive representing a 3d open path that can be supplied to GraphicBuilder.addPrimitive.  
GraphicPointString A GraphicPrimitive representing a point string that can be supplied to GraphicBuilder.addPrimitive.  
GraphicPointString2d A GraphicPrimitive representing a 2d point string that can be supplied to GraphicBuilder.addPrimitive.  
GraphicPolyface A GraphicPrimitive representing a mesh that can be supplied to GraphicBuilder.addPrimitive.  
GraphicPrimitive2d Base interface for a 2d GraphicPrimitive that can be supplied to GraphicBuilder.addPrimitive.  
GraphicShape A GraphicPrimitive representing a closed 3d planar region that can be supplied to GraphicBuilder.addPrimitive.  
GraphicShape2d A GraphicPrimitive representing a closed 2d region that can be supplied to GraphicBuilder.addPrimitive.  
GraphicSolidPrimitive A GraphicPrimitive representing a SolidPrimitive to be supplied to GraphicBuilder.addPrimitive.  
ParticleCollectionBuilder Interface for producing a collection of particles suitable for use in particle effects.  
ParticleCollectionBuilderParams Parameters used to construct a ParticleCollectionBuilder.  
ParticleProps Describes a particle to to add to a particle collection via ParticleCollectionBuilder.addParticle.  
PickableGraphicOptions Options used as part of GraphicBuilderOptions to describe a pickable RenderGraphic.  
QueryScreenFeaturesOptions Options specifying how to query for visible Features by reading pixels rendered by a Viewport. Beta
QueryTileFeaturesOptions Options specifying how to query for visible Features by inspecting the Tiles selected for display by a Viewport. Beta
RealityMeshProps  
RenderSystemDebugControl An interface optionally exposed by a RenderSystem that allows control of various debugging features. Beta
ScreenSpaceEffectBuilder An interface used to construct and register with the IModelApp.renderSystem a custom screen-space effect.  
ScreenSpaceEffectBuilderParams Parameters used to create a ScreenSpaceEffectBuilder.  
ScreenSpaceEffectContext Context passed to ScreenSpaceEffectBuilder.shouldApply.  
ScreenSpaceEffectSource The GLSL implementation of the effect produced by a ScreenSpaceEffectBuilder, to be integrated into a complete shader program.  
Uniform Represents a uniform variable in a shader program used by a custom screen-space effect, providing methods for setting the current value of the uniform.  
UniformArrayParams Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program.  
UniformContext Context supplied to UniformParams.bind.  
UniformParams Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program.  
VisibleFeature Represents a Feature determined to be visible within a Viewport. Beta

Namespaces

Name Description  
FeatureSymbology Contains types that enable an application to customize how Features are drawn within a Viewport.  
ParticleCollectionBuilder  
Pixel Describes aspects of a pixel as read from a Viewport.  
RenderSystem A RenderSystem provides access to resources used by the internal WebGL-based rendering system.  
TerrainMesh  

Type Aliases

Name Description  
AppearanceOverrideProps JSON representation of an appearance override in an EmphasizeElementsProps. Deprecated
CanvasDecorationList An array of CanvasDecorations.  
EmphasizeElementsProps JSON representation of an EmphasizeElements. Deprecated
FlashSettingsOptions Options used to construct or clone a FlashSettings.  
GraphicList An array of RenderGraphics.  
GraphicPrimitive Union type representing a graphic primitive that can be supplied to GraphicBuilder.addPrimitive.  
QueryVisibleFeaturesCallback  
QueryVisibleFeaturesOptions Options specifying how to query for visible Features. Beta

Last Updated: 29 November, 2022