ui-components Change Log

The ui-components package contains React components that are data-oriented, such as PropertyGrid, Table, Tree and Viewport. For more information, see learning about ui-components.

Topics

Name Description
Common Common classes used across various UI components.
Breadcrumb Classes and components for working with a Breadcrumb.
Color Classes and components for working with and picking a Color.
DateTimeTypeConverter Convert Date to string and string to Date.
DragDrop Classes and Higher Order Components for working with the DragDrop API.
Favorite Classes and components for displaying favorite properties.
Filtering Classes and components for working with filtering.
Inputs Input Components that format and parse input for IModelApps.
LineWeight Classes and components for working with and picking a Line Weight.
NavigationAids Classes and components for working with Navigation Aids.
OIDC Components for working with OIDC and Sign-in.
SelectableContent Classes and components for working with SelectableContent component.
Properties Classes and components for working with Properties.
PropertyEditors Classes and components for working with Property Editors.
PropertyGrid Classes and components for working with a PropertyGrid.
Table Classes and components for working with a Table.
Timeline Classes and components that provide a timeline
Toolbar Functions and components that provide a Toolbar.
Tree Classes and components for working with a Tree.
TypeConverters Classes for working with Type Converters.
Viewport Classes and components for working with a Viewport.
All Displays the contents of all topics in this package.

Last Updated: 29 November, 2022