DisplayStyles

Types for describing how the contents of Views should be rendered.

Classes

Name Description  
AmbientLight Describes the ambient light associated with a LightSettings.  
AnalysisStyle As part of a DisplayStyleSettings, describes how to animate meshes in the view that have been augmented with  
AnalysisStyleDisplacement Describes how an AnalysisStyle deforms a Polyface by applying translation to its vertices.  
AnalysisStyleScalar Describes how an AnalysisStyle recolors Polyface vertices by mapping scalar values supplied  
BackgroundMapSettings Normalized representation of a BackgroundMapProps for which type and provider have been validated and default values have been applied where explicit values not defined.  
ContextRealityModel A reality model not associated with a GeometricModel but instead defined in a DisplayStyle or DisplayStyleState.  
ContextRealityModels A list of ContextRealityModels attached to a DisplayStyleSettings.  
DisplayStyle3dSettings Provides access to the settings defined by a DisplayStyle3d or DisplayStyle3dState, and ensures that  
DisplayStyleSettings Provides access to the settings defined by a DisplayStyle or DisplayStyleState, and ensures that  
GroundPlane A circle drawn at a Z elevation, whose diameter is the the XY diagonal of the project extents, used to represent the ground as a reference point within a spatial view.  
HemisphereLights Describes a pair of hemisphere lights associated with a LightSettings.  
LightSettings Describes the lighting for a 3d scene, associated with a DisplayStyle3dSettings in turn associated with a DisplayStyle3d or DisplayStyle3dState.  
MapImagerySettings Provides access to the map imagery settings (Base and layers). Beta
MapLayerSettings Normalized representation of a MapLayerProps for which values have been validated and default values have been applied where explicit values not defined. Beta
MapSubLayerSettings Normalized representation of a MapSubLayerProps for which values Beta
PlanarClipMaskSettings Describes how to mask the geometry of one GeometricModel for display.  
PlanProjectionSettings Describes how to draw a plan projection model.  
SolarLight Describes the solar directional light associated with a LightSettings.  
SolarShadowSettings Settings controlling display of solar shadows for a DisplayStyle3dSettings.  
SpatialClassifier Describes how to use the geometry of one GeometricModel to classify the contents of other models - most typically, reality models.  
SpatialClassifierFlags Flags affecting how a SpatialClassifier is applied.  
SpatialClassifiers A set of SpatialClassifiers for a given reality model.  
SubCategoryOverride Overrides selected aspects of a SubCategoryAppearance in the context of a DisplayStyleState.  
TerrainSettings Normalized version of TerrainProps for which provider has been validated and default values of all members are used.  
ViewFlagOverrides Overrides a subset of ViewFlags.  
ViewFlags Flags for controlling how graphics appear within a View.  
WhiteOnWhiteReversalSettings As part of a DisplayStyleSettings, controls how white-on-white reversal is applied to make white geometry more  

Enumerations

Name Description  
BackgroundMapType Describes the type of background map displayed by a DisplayStyle  
GlobeMode Describes the projection of the background map  
MonochromeMode Describes the style in which monochrome color is applied by a DisplayStyleSettings.  
PlanarClipMaskMode The different modes by which a PlanarClipMaskSettings collects the geometry used to mask a model.  
PlanarClipMaskPriority The default priority values for a PlanarClipMaskSettings, based on model type.  
RenderMode Enumerates the available rendering modes.  
SkyBoxImageType Enumerates the supported types of SkyBox images.  
SpatialClassifierInsideDisplay Describes how a SpatialClassifier affects the display of classified geometry - that is, geometry intersecting  
SpatialClassifierOutsideDisplay Describes how a SpatialClassifier affects the display of unclassified geometry - that is, geometry not intersecting  
TerrainHeightOriginMode Correction modes for terrain height  
ViewFlagPresence Values used by ViewFlagOverrides to indicate which aspects of the ViewFlags are overridden.  

Interfaces

Name Description  
AmbientLightProps Wire format for the ambient light associated with a LightSettingsProps.  
AnalysisStyleDisplacementProps JSON representation of an AnalysisStyleDisplacement.  
AnalysisStyleProps JSON representation of an AnalysisStyle.  
AnalysisStyleScalarProps JSON representation of an AnalysisStyleScalar.  
BackgroundMapProps JSON representation of the settings associated with a background map displayed by a DisplayStyle.  
ContextRealityModelProps JSON representation of a ContextRealityModel.  
ContextRealityModelsContainer An object that can store the JSON representation of a list of ContextRealityModels.  
DisplayStyle3dProps JSON representation of a DisplayStyle3d or DisplayStyle3dState.  
DisplayStyle3dSettingsProps JSON representation of settings associated with a DisplayStyle3dProps.  
DisplayStyleModelAppearanceProps A FeatureAppearanceProps applied to a specific model to override its appearance within the context of a DisplayStyle.  
DisplayStyleOverridesOptions Controls which settings are serialized by DisplayStyleSettings.toOverrides.  
DisplayStylePlanarClipMaskProps A PlanarClipMaskProps associated with a specific reality model.  
DisplayStyleProps JSON representation of a DisplayStyle or DisplayStyleState.  
DisplayStyleSettingsOptions Options supplied when constructing a DisplayStyleSettings.  
DisplayStyleSettingsProps JSON representation of the settings associated with a DisplayStyleProps.  
DisplayStyleSubCategoryProps Describes the SubCategoryOverrides applied to a SubCategory by a DisplayStyle.  
EnvironmentProps JSON representation of the environment setup of a DisplayStyle3d.  
GroundPlaneProps JSON representation of a GroundPlane.  
HemisphereLightsProps Wire format for a pair of hemisphere lights associated with a LightSettingsProps.  
LightSettingsProps Wire format for a LightSettings describing lighting for a 3d scene.  
MapImageryProps The JSON representation of the map imagery. Beta
MapLayerKey stores key-value pair to be added to all requests made involving map layer. Beta
MapLayerProps JSON representation of the settings associated with a map layer. Beta
MapSubLayerProps JSON representation of the settings associated with a map sublayer included within a MapLayerProps. Beta
PlanarClipMaskProps JSON representation of a PlanarClipMaskSettings.  
PlanProjectionSettingsProps Wire format describing PlanProjectionSettings.  
SkyBoxImageProps JSON representation of an image or images used by a SkySphere or SkyCube.  
SkyBoxProps JSON representation of a SkyBox that can be drawn as the background of a ViewState3d.  
SkyCubeProps JSON representation of a set of images used by a SkyCube.  
SolarLightProps Wire format for the solar directional light associated with a LightSettingsProps.  
SolarShadowSettingsProps JSON representation of SolarShadowSettings.  
SpatialClassifierFlagsProps JSON representation of a SpatialClassifierFlags.  
SpatialClassifierProps JSON representation of a SpatialClassifier.  
SpatialClassifiersContainer An object that can store the JSON representation of a list of SpatialClassifiers.  
TerrainProps JSON representation of the settings of the terrain applied to background map display by a DisplayStyle.  
ViewFlagOverridesProps JSON representation of ViewFlagOverrides.  
ViewFlagProps JSON representation of ViewFlags  
WhiteOnWhiteReversalProps JSON representation of a WhiteOnWhiteReversalSettings.  

Namespaces

Name Description  
AmbientOcclusion Namespace containing types controlling how ambient occlusion should be drawn.  
ContextRealityModelProps  
HiddenLine Namespace containing types controlling how edges and surfaces should be drawn in "hidden line" and "solid fill" RenderModes.  
RenderSchedule Namespace containing types that collectively define a script that animates the contents of a view by adjusting the visibility, position,  

Type Aliases

Name Description  
BackgroundMapProviderName The current set of supported background map providers.  
BaseLayerProps The JSON representation of base layer properties -- these can be represented by either a full map layer or a simple color. Beta
BaseLayerSettings Normalized representation of base layer properties -- these can be represented by either a full map layer or a simple color. Beta
SubLayerId Beta
TerrainProviderName The current set of supported terrain providers.  

Last Updated: 29 November, 2022