imodeljs-frontend Change Log

The imodeljs-frontend package always runs in a web browser. It contains classes for querying iModels and showing views.

Topics

Name Description
IModelApp Classes for configuring and administering an iModel.js application.
IModelConnection Classes for working with a connection to an iModel briefcase
ElementState Classes for working with the state of Elements in the frontend.
ModelState Classes for working with the state of Models in the frontend.
Tools Classes for working with Tools
Measure Classes for reporting point to point distances and mass properties of elements.
Views Classes for working with Views
LocatingElements Classes for locating and snapping to elements in views.
AccuDraw AccuDraw provides helpful assistance for creating and modifying elements in a view.
Notifications Notifications provide feedback to the user of something of interest.
Extensions Classes for creating and managing runtime Extensions
Properties Classes for working with property records and descriptions.
Rendering Classes for rendering the contents of views.
SelectionSet Classes for working with the set of selected elements.
NativeApp Classes for working with Native Applications
OIDC Classes for working with the OpenID Connect (OIDC) protocol
Utils Miscellaneous utility classes.
Logging Logger categories used by this package
QuantityFormatting Classes for formatting and parsing quantity values.
Tiles Classes representing graphics as hierarchical 3d tiles.
Authentication Classes for managing authentication.
All Displays the contents of all topics in this package.

Last Updated: 29 November, 2022