RpcInterface

Types for working with RpcInterfaces.

Classes

Name Description  
BentleyCloudRpcConfiguration Operating parameters for Bentley cloud RPC interface deployments.  
BentleyCloudRpcManager Coordinates usage of RPC interfaces for Bentley cloud deployments.  
BentleyCloudRpcProtocol An http protocol for Bentley cloud RPC interface deployments.  
IModelNotFoundResponse Response if the IModelDb was not found at the backend  
IModelTileRpcInterface  
ResponseLike  
RpcConfiguration A RpcConfiguration specifies how calls on an RPC interface will be marshalled, plus other operating parameters.  
RpcControlResponse An RPC operation control response.  
RpcInterface An RPC interface is a set of operations exposed by a service that a client can call, using configurable protocols,  
RpcInvocation An RPC operation invocation in response to a request.  
RpcManager RPC interface management is concerned with coordination of access and configuration for RPC interfaces.  
RpcMultipartParser  
RpcNotFoundResponse A RPC operation response.  
RpcOperation An RPC operation descriptor.  
RpcOperationPolicy The policy for an RPC operation.  
RpcPendingResponse A pending RPC operation response.  
RpcProtocol An application protocol for an RPC interface.  
RpcRequest A RPC operation request.  
RpcRoutingToken  
WebAppRpcProtocol The HTTP application protocol.  
WebAppRpcRequest A web application RPC request.  

Enumerations

Name Description  
RpcContentType RPC content types.  
RpcEndpoint Endpoints for RPC protocols.  
RpcProtocolEvent RPC protocol event types.  
RpcRequestEvent RPC request event types.  
RpcRequestStatus The status of an RPC operation request.  
RpcResponseCacheControl Describes available options for RPC response caching.  

Interfaces

Name Description  
BentleyCloudRpcParams Initialization parameters for BentleyCloudRpcConfiguration.  
HttpServerRequest An HTTP server request object.  
HttpServerResponse An HTTP server response object.  
OpenAPIInfo An OpenAPI 3.0 info object.  
RpcInterfaceDefinition  
RpcInterfaceEndpoints Describes the endpoints of an RPC interface.  
RpcOperationsProfile Runtime information related to the operation load of one or more RPC interfaces.  
RpcRequestContext Interface to enable passing application-specific context with each RPC request.  
RpcRequestFulfillment An RPC operation request fulfillment.  
RpcSerializedValue  
SerializedRpcOperation A serialized RPC operation descriptor.  
SerializedRpcRequest A serialized RPC operation request.  

Namespaces

Name Description  
RpcOperation  
RpcRequestFulfillment  
RpcRequestStatus  
RpcSerializedValue  

Type Aliases

Name Description  
HttpMethod_T  
RpcConfigurationSupplier  
RpcInterfaceImplementation  
RpcInvocationCallback_T  
RpcOperationPolicyProps  
RpcProtocolEventHandler  
RpcRequestCallback_T  
RpcRequestEventHandler  
RpcRequestInitialRetryIntervalSupplier_T  
RpcRequestNotFoundHandler  
RpcRequestTokenSupplier_T  
RpcResponseCachingCallback_T  

Last Updated: 29 November, 2022