Tiles

Classes representing graphics as hierarchical 3d tiles.

Classes

Name Description  
BingElevationProvider Provides an interface to the Bing Maps elevation services.  
BingLocationProvider Provides an interface to the Bing Maps location services.  
DisclosedTileTreeSet A set of TileTrees disclosed by a set of objects implementing TileTreeDiscloser, used to collect references to tile trees in use by those objects.  
Tile A 3d tile within a TileTree.  
TileAdmin Manages Tiles and TileTrees on behalf of IModelApp.  
TileDrawArgs Provides context used when selecting and drawing Tiles.  
TileRequest Represents a pending or active request to load the contents of a Tile.  
TileRequestChannel A channel over which requests for tile content can be made.  
TileRequestChannels A set of named TileRequestChannels via which content for Tiles can be requested.  
TileRequestChannelStatistics Statistics regarding the current and cumulative state of one or more TileRequestChannels.  
TileTree A hierarchical level-of-detail tree of 3d Tiles to be rendered in a Viewport.  
TileTreeReference A reference to a TileTree suitable for drawing within a Viewport.  
TileUsageMarker A marker associated with a Tile to track usage of that tile by any number of viewports.  

Enumerations

Name Description  
TileBoundingBoxes Options for displaying tile bounding boxes for debugging purposes.  
TileGraphicType Describes the type of graphics produced by a TileTreeReference.  
TileLoadPriority Loosely describes the "importance" of a Tile.  
TileLoadStatus Describes the current status of a Tile's content.  
TileTreeLoadStatus Describes the current state of a TileTree.  
TileVisibility Describes the visibility of a tile based on its size and a view frustum.  

Global Functions

Name Description  
getCesiumAssetUrl Return the URL for a Cesium ION asset from its asset ID and request Key.  
readElementGraphics Convert the byte array returned by TileAdmin.requestElementGraphics into a RenderGraphic.  

Interfaces

Name Description  
DecodedPointCloud  
GpuMemoryLimits Defines separate GpuMemoryLimits for mobile and desktop clients.  
TileContent Describes the contents of a Tile.  
TileDrawArgParams Parameters used to construct TileDrawArgs.  
TileParams Parameters used to construct a Tile.  
TileTreeDiscloser Interface adopted by an object that contains references to TileTrees, to expose those trees.  
TileTreeOwner Owns and manages the lifecycle of a TileTree.  
TileTreeParams Parameters used to construct a TileTree.  
TileTreeSupplier Interface adopted by an object which can supply a TileTree for rendering.  

Namespaces

Name Description  
TileAdmin  
TileRequest  

Type Aliases

Name Description  
GpuMemoryLimit Describes a strategy for imposing limits upon the amount of GPU memory consumed by Tile content.  

Last Updated: 29 November, 2022