iModels

Classes for working with iModels. See the learning article.

Classes

Name Description  
AutoPush Use AutoPush to automatically push local changes to a specified IModel. Beta
BackendActivityMonitor An implementation of AppActivityMonitor that should be suitable for most backends. Beta
BriefcaseDb A local copy of an iModel from iModelHub that can pull and potentially push changesets.  
BriefcaseManager Manages downloading Briefcases and downloading and uploading changesets.  
ChangeSummaryManager Class to extract Change Summaries for a briefcase. Beta
ConcurrencyControl ConcurrencyControl enables an app to coordinate local changes with changes that are being made by others to an iModel. Beta
ExportGraphicsMeshVisitor * Iterator to walk the facets of an ExportGraphicsMesh and present them to the world as if visiting a Polyface.  
IModelCloneContext The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel. Beta
IModelDb An iModel database file.  
IModelExporter Base class for exporting data from an iModel. Beta
IModelExportHandler Handles the events generated by IModelExporter. Beta
IModelImporter Base class for importing data into an iModel. Beta
IModelTransformer Base class used to transform a source iModel into a different target iModel. Beta
SnapshotDb A snapshot iModel database file that is used for archival and data transfer purposes.  
StandaloneDb Standalone iModels are read/write files that are not managed by iModelHub.  
TemplateModelCloner IModelTransformer that clones the contents of a template model. Beta
TxnManager Manages local changes to a BriefcaseDb or StandaloneDb via Txns  

Enumerations

Name Description  
AutoPushEventType Identifies an AutoPush event. Beta
AutoPushState Identifies the current state of an AutoPush object. Beta
BriefcaseIdValue Deprecated
TxnAction Deprecated

Global Functions

Name Description  
setMaxEntitiesPerEvent Strictly for tests.  

Interfaces

Name Description  
AppActivityMonitor Monitors backend activity. Beta
AutoPushParams Configuration for AutoPush. Beta
ChangeSummary Represents an instance of the ChangeSummary ECClass from the ECDbChange ECSchema Beta
ChangeSummaryExtractOptions Options for ChangeSummaryManager.extractChangeSummaries. Beta
CheckpointProps Properties of a checkpoint  
ComputedProjectExtents The result of IModelDb.computeProjectExtents.  
ComputeProjectExtentsOptions Options supplied to IModelDb.computeProjectExtents.  
CreateChangeSummaryArgs Options for ChangeSummaryManager.createChangeSummaries. Beta
ExportGraphicsInfo Info provided to ExportGraphicsFunction about graphics.  
ExportGraphicsLines A collection of line segments, suitable for direct use with graphics APIs.  
ExportGraphicsMesh A triangulated mesh with unified indices, suitable for direct use with graphics APIs.  
ExportGraphicsOptions Parameters for IModelDb.exportGraphics  
ExportLinesInfo Info provided to ExportLinesFunction about linework graphics.  
ExportPartDisplayInfo Information about the base display properties when a GeometryPart was  
ExportPartGraphicsOptions Parameters for IModelDb.exportPartGraphics  
ExportPartInfo Info provided to ExportPartFunction about graphics.  
ExportPartInstanceInfo Information about references to GeometryPart elements found during  
ExportPartLinesInfo Info provided to ExportPartFunction about line graphics.  
IModelImportOptions Options provided to the IModelImporter constructor. Beta
IModelTransformOptions Options provided to the IModelTransformer constructor. Beta
InstanceChange Represents an instance of the InstanceChange ECClass from the ECDbChange ECSchema Beta
TxnChangedEntities Describes a set of Elements or Models that changed as part of a transaction.  
UpdateModelOptions Options for IModelDb.Models.updateModel  
ValidationError An error generated during dependency validation.  

Namespaces

Name Description  
ConcurrencyControl Beta
ExportGraphics Provides utility functions for working with data generated by IModelDb.exportGraphics  
IModelDb  

Type Aliases

Name Description  
AutoPushEventHandler  
BriefcaseId The Id assigned to a briefcase by iModelHub, or BriefcaseIdValue.Unassigned .  
ExportGraphicsFunction  
ExportLinesFunction  
ExportPartFunction  
ExportPartLinesFunction  
ProgressFunction  
RequestNewBriefcaseArg The argument for BriefcaseManager.downloadBriefcase  
TxnIdString A string that identifies a Txn.  

Last Updated: 29 November, 2022