imodeljs-backend

Classes

Name Description
AliCloudStorageService Beta
AnnotationElement2d 2d element used to annotate drawings and sheets.
AuthorizedBackendRequestContext Provides some generic context for downstream server applications to get details of a request that
AutoPush Use AutoPush to automatically push local changes to a specified IModel. Beta
AuxCoordSystem An auxiliary coordinate system element.
AuxCoordSystem2d A 2d auxiliary coordinate system.
AuxCoordSystem3d A 3d auxiliary coordinate system.
AuxCoordSystemSpatial A spatial auxiliary coordinate system.
AzureBlobStorage Beta
BackendActivityMonitor An implementation of AppActivityMonitor that should be suitable for most backends. Beta
BackendRequestContext Provides generic context for downstream server applications to get details of a request that
BisCoreSchema The BisCore schema is the lowest level Schema in an iModel.
BriefcaseDb A local copy of an iModel from iModelHub that can pull and potentially push changesets.
BriefcaseManager Manages downloading Briefcases and downloading and uploading changesets.
Callout A graphical DetailingSymbol that calls out a reference to another drawing.
Category A Category element is the target of the category member of GeometricElement.
CategoryOwnsSubCategories Relates a parent Category to SubCategory child elements.
CategorySelector Holds a list of Ids of Categories to be displayed in a view.
ChangeSummaryManager Class to extract Change Summaries for a briefcase. Beta
ChannelRootAspect A ChannelRootAspect identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained.
ClassRegistry The mapping between a BIS class name (in the form "schema:class") and its JavaScript constructor function
CloudStorageService Beta
CodeSpecs Manages CodeSpecs within an IModelDb
ConcurrencyControl ConcurrencyControl enables an app to coordinate local changes with changes that are being made by others to an iModel. Beta
DefinitionContainer A DefinitionContainer exclusively owns a set of DefinitionElements contained within its sub-model (of type DefinitionModel).
DefinitionElement A Definition Element holds configuration-related information that is meant to be referenced / shared.
DefinitionGroup A non-exclusive set of DefinitionElements grouped using the DefinitionGroupGroupsDefinitions relationship.
DefinitionGroupGroupsDefinitions Relates a DefinitionGroup to its DefinitionElement members.
DefinitionModel A container for persisting definition elements.
DefinitionPartition A DefinitionPartition element establishes a Definition modeling perspective for its parent Subject.
DefinitionSet This abstract class unifies DefinitionGroup and DefinitionContainer for relationship endpoint purposes.
DetailCallout A graphical Callout that references a detail drawing.
DetailingSymbol A graphical detailing symbol that is placed on a Drawing or Sheet.
DictionaryModel The singleton container for repository-specific definition elements.
DisplayStyle A DisplayStyle defines the parameters for 'styling' the contents of a view.
DisplayStyle2d A DisplayStyle for 2d views.
DisplayStyle3d A DisplayStyle for 3d views.
Document An InformationContentElement that identifies the content of a document.
DocumentListModel Contains a list of document elements.
DocumentPartition A DocumentPartition element establishes a Document modeling perspective for its parent Subject.
Drawing A document that represents a drawing, that is, a two-dimensional graphical representation of engineering data.
DrawingCategory Categorizes 2d GeometricElements.
DrawingGraphic 2d element used to persist graphics for use in drawings.
DrawingGraphicRepresentsElement Relates a DrawingGraphic to the Element that it represents
DrawingGraphicRepresentsFunctionalElement Relates a DrawingGraphic to the FunctionalElement that it represents
DrawingModel A 2d model that holds DrawingGraphics.
DrawingViewDefinition Defines a view of a DrawingModel.
DriverBundleElement Element used in conjunction with bis:ElementDrivesElement relationships to bundle multiple inputs before Beta
ECDb An ECDb file
ECSqlBinder Binds a value to an ECSQL parameter.
ECSqlInsertResult The result of an ECSQL INSERT statement as returned from ECSqlStatement.stepForInsert.
ECSqlStatement Executes ECSQL statements.
ECSqlValue Value of a column in a row of an ECSQL query result.
ECSqlValueIterator Iterator over members of a struct ECSqlValue or the elements of an array ECSqlValue.
Element Elements are the smallest individually identifiable building blocks for modeling the real world in an iModel.
ElementAspect An Element Aspect is a class that defines a set of properties that are related to (and owned by) a single element.
ElementDrivesElement A Relationship indicating that one Element drives another Element. Beta
ElementEncapsulatesElements Relates a parent Element to child Elements which represent hidden parts of the Entity.
ElementGroupsMembers An ElementRefersToElements relationship where one Element groups a set of other Elements.
ElementMultiAspect An Element Multi-Aspect is an ElementAspect where there can be n instances of the Element Aspect class per Element.
ElementOwnsChildElements Relates a parent Element to child Elements which represent parts of the Entity modeled by the parent Element.
ElementOwnsExternalSourceAspects Relates an Element and an ExternalSourceAspect that it owns.
ElementOwnsMultiAspects Relates an Element and an ElementMultiAspect that it owns.
ElementOwnsUniqueAspect Relates an Element and an ElementUniqueAspect that it owns.
ElementRefersToElements A Relationship where one Element refers to another Element
ElementUniqueAspect An Element Unique Aspect is an ElementAspect where there can be only zero or one instance of the Element Aspect class per Element.
ElevationCallout A graphical Callout that references an elevation drawing.
An information element that links to an embedded file.
Entity Base class for all Entities in an iModel.
ExportGraphicsMeshVisitor * Iterator to walk the facets of an ExportGraphicsMesh and present them to the world as if visiting a Polyface.
ExternalSource An ExternalSource refers to an 'information container' found in a repository. Beta
ExternalSourceAspect An ElementMultiAspect that stores synchronization information for an Element originating from an external source.
ExternalSourceAttachment Attachment of an ExternalSource Beta
ExternalSourceAttachmentAttachesSource Relates an ExternalSource to the RepositoryLink that it is persisted in. Beta
ExternalSourceGroup A group of ExternalSources that are collectively a source of information for one or more elements. Beta
ExternalSourceGroupGroupsSources Relates an ExternalSourceGroup to its ExternalSource members. Beta
ExternalSourceIsInRepository Relates an ExternalSource to the RepositoryLink that it is persisted in. Beta
ExternalSourceOwnsAttachments Relates a parent ExternalSource to its ExternalSourceAttachment children. Beta
FileNameResolver Extend this class to provide custom file name resolution behavior.
FolderContainsRepositories Relates a parent FolderLink to its RepositoryLink children. Beta
FunctionalBreakdownElement A FunctionalBreakdownElement is a folder node in the functional hierarchy.
FunctionalComponentElement A FunctionalComponentElement is a leaf node in the functional hierarchy.
FunctionalComposite
FunctionalElement A FunctionalElement captures functional requirements that will ultimately be fulfilled by a PhysicalElement.
FunctionalElementIsOfType Relates a FunctionalElement to its FunctionalType
FunctionalModel A container for persisting FunctionalElements.
FunctionalPartition A FunctionalPartition element is a key part of the iModel information hierarchy and is always parented
FunctionalSchema
FunctionalType Defines a set of properties (the 'type') that can be associated with a Functional Element.
GenericDocument The Generic:Document class is used when a document cannot be further classified.
GenericGraphicalModel3d A generic container for persisting BisCore:GraphicalElement3d instances.
GenericGraphicalType2d The Generic:GraphicalType2d class is used when graphical types cannot be further classified.
GenericPhysicalMaterial The Generic:PhysicalMaterial class is used when the physical material cannot be further classified.
GenericPhysicalType The Generic:PhysicalType class is used when the physical type cannot be further classified.
GenericSchema
GeometricElement An abstract base class to model real world entities that intrinsically have geometry.
GeometricElement2d An abstract base class to model information entities that intrinsically have 2d geometry.
GeometricElement2dHasTypeDefinition Relates a GeometricElement2d to its TypeDefinitionElement
GeometricElement3d An abstract base class to model real world entities that intrinsically have 3d geometry.
GeometricElement3dHasTypeDefinition Relates a GeometricElement3d to its TypeDefinitionElement
GeometricModel A container for persisting geometric elements.
GeometricModel2d A container for persisting 2d geometric elements.
GeometricModel3d A container for persisting 3d geometric elements.
GeometryPart A Definition Element that specifies a collection of geometry that is meant to be reused across Geometric
Graphic3d The Generic:Graphic3d class is used when 3D graphics cannot be further classified.
GraphicalElement2d An abstract base class for 2d Geometric Elements that are used to convey information within graphical presentations (like drawings).
GraphicalElement2dIsOfType Relates a GraphicalElement2d to its GraphicalType2d
GraphicalElement3d A 3d Graphical Element
GraphicalElement3dRepresentsElement Relates a GraphicalElement3d to the Element that it represents
GraphicalModel2d A container for persisting 2d graphical elements.
GraphicalModel3d A container for persisting GraphicalElement3d instances.
GraphicalPartition3d A GraphicalPartition3d element establishes a 3D Graphical modeling perspective for its parent Subject.
GraphicalType2d Defines a set of properties (the type) that can be associated with a 2D Graphical Element.
Group The Generic:Group class is used when the group cannot be further classified.
GroupImpartsToMembers Represents group membership where the group Element (and its properties) impart information about the member Elements above mere membership.
GroupInformationElement Group Information is an abstract base class for modeling entities whose main purpose is to reference a group of related elements.
GroupInformationModel A container for persisting group information elements.
GroupInformationPartition A GroupInformationPartition element establishes a Group Information modeling perspective for its parent Subject.
GroupModel A generic container for BisCore:GroupInformationElement instances.
IModelCloneContext The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel. Beta
IModelDb An iModel database file.
IModelExporter Base class for exporting data from an iModel. Beta
IModelExportHandler Handles the events generated by IModelExporter. Beta
IModelHost IModelHost initializes imodeljs-backend and captures its configuration.
IModelHostConfiguration Configuration of imodeljs-backend.
IModelImporter Base class for importing data into an iModel. Beta
IModelJsFs File system operations that are defined on all platforms.
IModelJsFsStats Information about a file.
IModelTransformer Base class used to transform a source iModel into a different target iModel. Beta
InformationContentElement Information Content Element is an abstract base class for modeling pure information entities.
InformationModel A container for persisting information elements.
InformationPartitionElement An abstract base class for elements that establishes a particular modeling perspective for its parent Subject.
InformationRecordElement Information Record Element is an abstract base class for modeling information records.
InformationRecordModel A container for persisting Information Record Elements
InformationRecordPartition An InformationRecordPartition element establishes a Information Record modeling perspective for its parent Subject.
InformationReferenceElement Information Reference is an abstract base class for modeling entities whose main purpose is to reference something else.
IpcHandler Base class for all implementations of an Ipc interface.
IpcHost Used by applications that have a dedicated backend.
KnownLocations Well known directories that may be used by the application.
LineStyle The definition element for a line style
LinkElement An information element that specifies a link.
LinkModel A container for persisting link elements.
LinkPartition A LinkPartition element establishes a Link modeling perspective for its parent Subject.
Model A Model is a container for persisting a collection of related elements within an iModel.
ModelSelector Holds the list of Ids of GeometricModels displayed by a SpatialViewDefinition.
NativeAppStorage A local file stored in the NativeHost.appSettingsCacheDir for storing key/value pairs.
NativeHost Backend for desktop/mobile native applications
OrthographicViewDefinition Defines a spatial view that displays geometry on the image plane using a parallel orthographic projection.
PhysicalElement An Element that is spatially located, has mass, and can be touched.
PhysicalElementAssemblesElements Relates a parent PhysicalElement to PhysicalElement children that it assembles.
PhysicalElementFulfillsFunction Relates a PhysicalElement to the FunctionalElement elements that it fulfills.
PhysicalElementIsOfPhysicalMaterial Relates a PhysicalElement to its PhysicalMaterial
PhysicalElementIsOfType Relates a PhysicalElement to its PhysicalType
PhysicalMaterial A PhysicalMaterial defines the matter that makes up physical elements.
PhysicalModel A container for persisting physical elements that model physical space.
PhysicalObject The Generic:PhysicalObject class is used when physical elements cannot be further classified.
PhysicalPartition A PhysicalPartition element establishes a Physical modeling perspective for its parent Subject.
PhysicalType Defines a set of properties (the type) that can be associated with a Physical Element.
PhysicalTypeIsOfPhysicalMaterial Relates a PhysicalType to its PhysicalMaterial
PlanCallout A graphical Callout that references a plan drawing.
Platform Information about the platform on which the app is running.
RecipeDefinitionElement Defines a recipe for generating instances from a definition. Beta
Relationship Base class for all link table ECRelationships
Relationships Manages Relationships.
RenderMaterialElement Defines a rendering material.
RenderMaterialOwnsRenderMaterials Relates a parent RenderMaterial to RenderMaterial child elements.
RenderTimeline Describes how to animate a view of a GeometricModel to show change over time using a RenderSchedule.Script.
An information element that links to a repository.
RepositoryModel The singleton container of repository-related information elements.
RoleElement A real world entity is modeled as a Role Element when a set of external circumstances define an important
RoleModel A container for persisting role elements.
Schema Base class for all schema classes - see working with schemas and elements in TypeScript.
Schemas Manages registered schemas
SectionCallout A graphical Callout that references a section drawing.
SectionDrawing A document that represents a section drawing, that is, a graphical documentation derived from a planar
SectionDrawingLocation A SectionDrawingLocation element identifies the location of a SectionDrawing in the context of a SpatialModel,
SectionDrawingModel A container for persisting section DrawingGraphics.
Sheet A digital representation of a sheet of paper.
SheetBorderTemplate The template for a SheetBorder
SheetModel A container for persisting ViewAttachments and DrawingGraphics.
SheetTemplate The template for a Sheet
SheetViewDefinition Defines a view of a SheetModel.
SnapshotDb A snapshot iModel database file that is used for archival and data transfer purposes.
SpatialCategory Categorizes SpatialElements.
SpatialElement An Element that occupies real world space.
SpatialLocation The Generic:SpatialLocation class is used when spatial locations cannot be further classified.
SpatialLocationElement Identifies a tracked real world location but has no mass and cannot be touched.
SpatialLocationIsOfType Relates a SpatialLocationElement to its SpatialLocationType
SpatialLocationModel A container for persisting spatial location elements.
SpatialLocationPartition A SpatialLocationPartition element establishes a SpatialLocation modeling perspective for its parent Subject.
SpatialLocationType Defines a set of properties (the type) that can be associated with a spatial location.
SpatialModel A container for persisting 3d geometric elements that are spatially located.
SpatialViewDefinition Defines a view of one or more SpatialModels.
SQLiteDb A SQLiteDb file
SqliteStatement Executes SQLite SQL statements.
SqliteValue Value of a column in a row of an SQLite SQL query result.
StandaloneDb Standalone iModels are read/write files that are not managed by iModelHub.
SubCategory Defines the appearance for graphics in Geometric elements
Subject A Subject is an information element that describes what this repository (or part thereof) is about.
SubjectOwnsPartitionElements Relates a parent Subject to InformationPartitionElement child elements.
SubjectOwnsSubjects Relates a parent Subject to Subject child elements.
Link to the Configuration for an iModel Synchronization Job Beta
SynchronizationConfigProcessesSources Relates a SynchronizationConfigLink to N ExternalSource instances. Beta
SynchronizationConfigSpecifiesRootSources Relates a SynchronizationConfigLink to root ExternalSource instances. Beta
TemplateModelCloner IModelTransformer that clones the contents of a template model. Beta
TemplateRecipe2d A recipe that uses a 2D template for creating new instances. Beta
TemplateRecipe3d A TemplateRecipe3d is a DefinitionElement that has a sub-model that contains the 3d template elements. Beta
TextAnnotation2d 2D Text Annotation
TextAnnotation3d 3D Text Annotation
Texture Defines a rendering texture that is associated with a Material and applied to surface geometry.
TitleText A graphical DetailingSymbol that contains title text.
TxnManager Manages local changes to a BriefcaseDb or StandaloneDb via Txns
TypeDefinitionElement Defines a set of properties (the type) that may be associated with an element.
An information element that specifies a URL link.
ViewAttachment Represents an attachment of a ViewDefinition to a Sheet.
ViewAttachmentLabel A graphical DetailingSymbol that contains a view attachment label.
ViewDefinition The definition element for a view.
ViewDefinition2d Defines a view of a single 2d model.
ViewDefinition3d Defines a view of one or more 3d models.
VolumeElement A Volume Element is a Spatial Location Element that is restricted to defining a volume.
WebMercatorModel Obtains and displays multi-resolution tiled raster organized according to the WebMercator tiling system.

Enumerations

Name Description
AutoPushEventType Identifies an AutoPush event. Beta
AutoPushState Identifies the current state of an AutoPush object. Beta
BackendLoggerCategory Logger categories used by this package
BriefcaseIdValue Deprecated
ECDbOpenMode Modes for how to open ECDb files.
LockScope The scope of a lock.
SqliteValueType Data type of a value in in an SQLite SQL query result.
TxnAction Deprecated

Global Functions

Name Description
initializeRpcBackend
setMaxEntitiesPerEvent Strictly for tests.

Interfaces

Name Description
AppActivityMonitor Monitors backend activity. Beta
AutoPushParams Configuration for AutoPush. Beta
ChangeSummary Represents an instance of the ChangeSummary ECClass from the ECDbChange ECSchema Beta
ChangeSummaryExtractOptions Options for ChangeSummaryManager.extractChangeSummaries. Beta
CheckpointProps Properties of a checkpoint
CloudStorageServiceCredentials Beta
CloudStorageUploadOptions Beta
ComputedProjectExtents The result of IModelDb.computeProjectExtents.
ComputeProjectExtentsOptions Options supplied to IModelDb.computeProjectExtents.
CreateChangeSummaryArgs Options for ChangeSummaryManager.createChangeSummaries. Beta
DisplayStyleCreationOptions Describes initial settings for a new DisplayStyle3d.
ECEnumValue Represents the value of an ECEnumeration.
ECSqlColumnInfo Information about an ECSQL column in an ECSQL query result.
ElementDrivesElementProps Properties that are common to all types of ElementDrivesElements Beta
ElementGroupsMembersProps Properties that are common to all types of link table ECRelationships
ExportGraphicsInfo Info provided to ExportGraphicsFunction about graphics.
ExportGraphicsLines A collection of line segments, suitable for direct use with graphics APIs.
ExportGraphicsMesh A triangulated mesh with unified indices, suitable for direct use with graphics APIs.
ExportGraphicsOptions Parameters for IModelDb.exportGraphics
ExportLinesInfo Info provided to ExportLinesFunction about linework graphics.
ExportPartDisplayInfo Information about the base display properties when a GeometryPart was
ExportPartGraphicsOptions Parameters for IModelDb.exportPartGraphics
ExportPartInfo Info provided to ExportPartFunction about graphics.
ExportPartInstanceInfo Information about references to GeometryPart elements found during
ExportPartLinesInfo Info provided to ExportPartFunction about line graphics.
IModelImportOptions Options provided to the IModelImporter constructor. Beta
IModelTransformOptions Options provided to the IModelTransformer constructor. Beta
InstanceChange Represents an instance of the InstanceChange ECClass from the ECDbChange ECSchema Beta
IpcHostOpts Options for IpcHost.startup
LockProps The properties of an iModel server lock. Beta
NativeHostOpts Options for NativeHost.startup
OnAspectArg Argument for the ElementAspect.onXxx static methods Beta
OnAspectIdArg Argument for the ElementAspect.onXxx static methods that only supply the Id of the affected aspect. Beta
OnAspectPropsArg Argument for the ElementAspect.onXxx static methods that supply the properties of an aspect to be inserted or updated. Beta
OnChildElementArg Argument for the Element.onChildXxx static methods Beta
OnChildElementIdArg Argument for the Element.onChildXxx static methods that only supply the Id of the child Element. Beta
OnChildElementPropsArg Argument for the Element.onChildXxx static methods that supply the properties of the child Element to be inserted or updated. Beta
OnElementArg Argument for the Element.onXxx static methods Beta
OnElementIdArg Argument for the Element.onXxx static methods that only supply the Id of the affected Element. Beta
OnElementInModelIdArg Argument for the Model.onXxxElement static methods that supply the Id of an Element for a Model. Beta
OnElementInModelPropsArg Argument for the Model.onXxxElement static methods that supply the properties of an Element for a Model. Beta
OnElementPropsArg Argument for Element.onInsert and Element.onUpdate static methods. Beta
OnModelArg Argument for the Model.onXxx static methods Beta
OnModelIdArg Argument for the Model.onXxx static methods that only supply the Id of the affected Model. Beta
OnModelPropsArg Argument for the Model.onXxx static methods that supply the properties of a Model to be inserted or updated. Beta
OnSubModelIdArg Argument for several Element.onSubModelXxx static methods Beta
OnSubModelPropsArg Argument for the Element.onSubModelInsert static method Beta
RelationshipProps Properties that are common to all types of link table ECRelationships
SourceAndTarget Specifies the source and target elements of a Relationship instance.
TxnChangedEntities Describes a set of Elements or Models that changed as part of a transaction.
UpdateModelOptions Options for IModelDb.Models.updateModel
V2CheckpointAccessProps The properties to access a V2 checkpoint through a daemon. Beta
ValidationError An error generated during dependency validation.

Namespaces

Name Description
ConcurrencyControl Beta
ExportGraphics Provides utility functions for working with data generated by IModelDb.exportGraphics
ExternalSourceAspect
IModelDb
LineStyleDefinition A line style definition is a uniquely named pattern that repeats as it is displayed along a curve path.
RenderMaterialElement

Type Aliases

Name Description
AutoPushEventHandler
BindParameter parameter Index (1-based), or name of the parameter (including the initial ':', '@' or '$')
BriefcaseId The Id assigned to a briefcase by iModelHub, or BriefcaseIdValue.Unassigned .
EntityClassType Parameter type that can accept both abstract constructor types and non-abstract constructor types for instanceof to test.
ExportGraphicsFunction
ExportLinesFunction
ExportPartFunction
ExportPartLinesFunction
GenerateKeyFnType
MemoizeFnType
ProgressFunction
RequestNewBriefcaseArg The argument for BriefcaseManager.downloadBriefcase
TxnIdString A string that identifies a Txn.

Last Updated: 29 November, 2022