Common

Common classes used across various UI components.

Classes

Name Description  
ShowHideDialog Dialog Component used to toggle show/hide items, given through items prop, through a list of checkboxes.  
ShowHideMenu ContextMenu Component used to toggle show/hide items, given through items prop, through a list of checkboxes.  
UiComponents Manages the I18N service for the ui-components package.  

Enumerations

Name Description  
SelectionMode Selection modes for Table and Tree row selection  
SelectionModeFlags Selection mode flags for Table and Tree row selection  
StandardTypeConverterTypeNames StandardTypeConverterTypeNames. Beta
StandardTypeNames Standard Type Names for converters and editors. Beta

Global Functions

Name Description  
adjustDateToTimezone Adjust a Date object to show time in one time zone as if it is in the local time zone.  
hasFlag Determines if a SelectionMode is active Deprecated
hasSelectionModeFlag Determines if a SelectionMode is active  
HighlightedText Highlighted text Beta
Returns a list of links from a text  
toDateString Format a date in a display string, optionally converting to time zone, if specified by timeZoneOffset  
toTimeString Format the time included in a date, optionally converting to time zone, if specified  
useAsyncValue Custom hook for working with possibly async values. Beta

Interfaces

Name Description  
HighlightedTextProps Properties of HighlightedText Beta
HighlightInfo Item highlight info used for identification of a specific highlight in an item Beta
HighlightingComponentProps Properties used for highlighting parts in item by given text and actively highlighting one highlight in a distinct item specified in activeHighlight Beta
IImageLoader Interface for an image loader.  
LoadedBinaryImage Image data for raw images  
LoadedImage Image data for string based images  
PageOptions Paging options.  
ShowHideDialogProps Properties for the ShowHideDialog component  
ShowHideItem Interface for ShowHide items  
ShowHideMenuProps Properties for the ShowHideMenu component  

Type Aliases

Name Description  
Image Image data returned by an IImageLoader  
ImageFileFormat Type of raw image format  
ImageSourceType Type of loaded image source:  
OnItemsDeselectedCallback  
OnItemsSelectedCallback  
OnSelectionChanged  
ShowHideID Union type for all possible ShowHide IDs  

Last Updated: 29 November, 2022