DelegationAuthorizationClient Class

Beta  

Utility to generate delegation OAuth or legacy SAML tokens for backend applications

Extends

Methods

Name Description
constructor(configuration: BackendAuthorizationClientConfiguration): DelegationAuthorizationClient Creates an instance of BackendAuthorizationClient.  
getJwtFromJwt(requestContext: ClientRequestContext, accessToken: AccessToken): Promise<AccessToken> Get a delegation JWT for a new scope from another JWT  
getJwtFromSaml(requestContext: ClientRequestContext, samlToken: SamlAccessToken): Promise<AccessToken> Get a JWT for the specified scope from a SAML token  
getSamlFromJwt(requestContext: ClientRequestContext, accessToken: AccessToken): Promise<SamlAccessToken> Get a SAML token for the specified scope from a JWT token  

Inherited methods

Name Inherited from Description
applyUserConfiguredHttpRequestOptions(requestOptions: RequestOptions, userDefinedRequestOptions?: HttpRequestOptions): void Protected BackendAuthorizationClient Configures request options based on user defined values in HttpRequestOptions
delete(requestContext: AuthorizedClientRequestContext, relativeUrlPath: string, httpRequestOptions?: HttpRequestOptions): Promise<void> Protected BackendAuthorizationClient used by clients to send delete requests
discoverEndpoints(requestContext: ClientRequestContext): Promise<Issuer<Client>> BackendAuthorizationClient Discover the endpoints of the service
getClient(requestContext: ClientRequestContext): Promise<Client> Protected BackendAuthorizationClient  
getUrl(requestContext: ClientRequestContext): Promise<string> BackendAuthorizationClient Gets the URL of the service.
getUrlSearchKey(): string Protected BackendAuthorizationClient Gets name/key to query the service URLs from the URL Discovery Service ("Buddi")
setupOptionDefaults(options: RequestOptions): Promise<void> Protected BackendAuthorizationClient Augments request options with defaults returned by the DefaultRequestOptionsProvider.

Inherited properties

Name Type Inherited from Description
_configuration Protected BackendAuthorizationClientConfiguration BackendAuthorizationClient  
_url Protected undefined | string BackendAuthorizationClient  
baseUrl Protected undefined | string BackendAuthorizationClient Sets the default base URL to use with this client.
searchKey StaticReadonly string BackendAuthorizationClient  

Defined in

Last Updated: 29 November, 2022