ContextRegistryRequestQueryOptions Interface

Beta  

Options to request iTwin contexts.

Extends

Properties

Name Type Description
isFavorite undefined | boolean Set to true to request the favorite projects  
isMRU undefined | boolean Set to true to request the most recently used projects  

Inherited properties

Name Type Inherited from Description
$filter undefined | string RequestQueryOptions Filter string used by the query (use the mapped EC property names, and not TypeScript property names)
$orderby undefined | string RequestQueryOptions Orders the return values (use the mapped EC property names, and not TypeScript property names)
$pageSize undefined | number RequestQueryOptions Sets the limit on the number of entries to be returned by a single response.
$select undefined | string RequestQueryOptions Select string used by the query (use the mapped EC property names, and not TypeScript property names)
$skip undefined | number RequestQueryOptions Sets the number of entries to be skipped
$top undefined | number RequestQueryOptions Sets the limit on the number of entries to be returned by the query

Defined in

Last Updated: 29 November, 2022