BrowserAuthorizationLogger Class

Beta  

Utility to forward oidc-client logs to the Bentley logger Because the logger used by the oidc-client library is static, we can't tie specific UserManager instances to different logging categories. Thus, the best we can do is tie all logs originating from the library to a single logging category (derived from the name of this class).

Implements

Methods

Name Description
debug(message?: any, ...optionalParams: any[]): void    
error(message?: any, ...optionalParams: any[]): void    
info(message?: any, ...optionalParams: any[]): void    
warn(message?: any, ...optionalParams: any[]): void    
getLogLevel(loggerCategory: string): number ProtectedStatic    
initializeLogger(): void Static Initializes forwarding of OidcClient logs to the Bentley Logger  
reset(): void Static Resets (or clears) forwarding of OidcClient logs to the Bentley Logger  

Defined in

Last Updated: 29 November, 2022