clipPolyfaceInsideOutside MethodStatic
Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet
- accumulate inside and outside facets -- to destination.builderA and destination.builderB
- if
destination.buildClosureFaces
is set, and also build closure facets - This method parses the variant input types and calls a more specific method.
- WARNING: The new mesh is "points only".
clipPolyfaceInsideOutside(polyface: Polyface, clipper: ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders): void
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets | |
destination | ClippedPolyfaceBuilders |
Returns - void
Defined in
- polyface/PolyfaceClip.ts Line 383
Last Updated: 11 June, 2024