IModelCreateOptions Interface

Options used when creating an HubIModel with IModelHandler.create or IModelsHandler.create.

Properties

Name Type Description
description undefined | string Description of the iModel on the Hub.  
extent undefined | number[] Extent of iModel.  
iModelType undefined | IModelType Type of iModel.  
path undefined | string iModel seed file path.  
progressCallback undefined | ProgressCallback Callback for tracking progress.  
timeOutInMilliseconds undefined | number Time to wait for iModel initialization.  

Defined in

Last Updated: 29 November, 2022