populateRequest MethodStatic

Beta  

Disclose the codes and locks needed to perform the specified operation on this element

populateRequest(req: ConcurrencyControl.Request, props: ElementProps, iModel: IModelDb, opcode: DbOpcode, original: undefined | ElementProps): void

Parameter Type Description
req ConcurrencyControl.Request the request to populate
props ElementProps the version of the element that will be written
iModel IModelDb the iModel
opcode DbOpcode the operation
original undefined | ElementProps a pre-change copy of the element. Passed only in the case of Update.

Returns - void

Defined in

Last Updated: 29 November, 2022