upgradeSchemas MethodStatic

Upgrades the schemas in the iModel based on the current version of the software. Follows a sequence of operations -

  • Acquires a schema lock to prevent other users from making a concurrent upgrade
  • Updates the local briefcase with the schema changes.
  • Pushes the resulting change set(s) to the iModel Hub. Note that the upgrade requires that the local briefcase be closed, and may result in one or two change sets depending on whether both profile and domain schemas need to get upgraded. At the end of the call, the local database is left back in the closed state.

upgradeSchemas(requestContext: AuthorizedClientRequestContext, briefcase: LocalBriefcaseProps & OpenBriefcaseProps): Promise<void>

throws IModelError If there was a problem with upgrading schemas

see BriefcaseDb.validateSchemas

see ($docs/learning/backend/IModelDb.md#upgrading-schemas-in-an-imodel)

Parameter Type Description
requestContext AuthorizedClientRequestContext The context for authorization to push upgraded change sets
briefcase LocalBriefcaseProps & OpenBriefcaseProps  

Returns - Promise<void>

Defined in

Last Updated: 29 November, 2022