startBulkMode Method

Beta  

Start "bulk update mode". This mode is designed for bulk-loading or bulk-updating apps. It avoids the expense of acquiring many locks and codes individually by deferring them to a single bulk request at the end. In bulk update mode, you don't have to request locks and codes on elements or models before changing them in the briefcase. Instead, ConcurrencyControl keeps track of the locks and codes that will be needed needed. You must call endBulkMode before calling BriefcaseDb.saveChanges. That sends a single request for all of the required resources. Bulk update mode works with either optimistic or pessimistic concurrency policy. Bulk update mode does not represent different locking policy; it just defers the request of locks and codes. Bulk mode is a reasonable choice only when you know there is no chance of conflicts.

startBulkMode(): void

Returns - void

Defined in

Last Updated: 29 November, 2022