IModelExportHandler Class

Handles the events generated by IModelExporter.

note Change information is available when IModelExportHandler methods are invoked via IModelExporter.exportChanges, but not available when invoked via IModelExporter.exportAll.

see iModel Transformation and Data Exchange, IModelExporter

Extended by

Methods

Name Description
constructor(): IModelExportHandler    
onDeleteElement(_elementId: string): void Protected Called when an element should be deleted.  
onDeleteModel(_modelId: string): void Protected Called when a model should be deleted.  
onDeleteRelationship(_relInstanceId: string): void Protected Called when a relationship should be deleted.  
onExportCodeSpec(_codeSpec: CodeSpec, _isUpdate: undefined | boolean): void Protected Called when a CodeSpec should be exported.  
onExportElement(_element: Element, _isUpdate: undefined | boolean): void Protected Called when an element should be exported.  
onExportElementMultiAspects(_aspects: ElementMultiAspect[]): void Protected Called when ElementMultiAspects should be exported.  
onExportElementUniqueAspect(_aspect: ElementUniqueAspect, _isUpdate: undefined | boolean): void Protected Called when an ElementUniqueAspect should be exported.  
onExportFont(_font: FontProps, _isUpdate: undefined | boolean): void Protected Called when a font should be exported.  
onExportModel(_model: Model, _isUpdate: undefined | boolean): void Protected Called when a model should be exported.  
onExportRelationship(_relationship: Relationship, _isUpdate: undefined | boolean): void Protected Called when a Relationship should be exported.  
onExportSchema(_schema: Schema): Promise<void> Protected Called when an schema should be exported.  
onProgress(): Promise<void> Protected This method is called when IModelExporter has made incremental progress based on the IModelExporter.progressInterval setting.  
shouldExportCodeSpec(_codeSpec: CodeSpec): boolean Protected If true is returned, then the CodeSpec will be exported.  
shouldExportElement(_element: Element): boolean Protected If true is returned, then the element will be exported.  
shouldExportElementAspect(_aspect: ElementAspect): boolean Protected If true is returned, then the ElementAspect will be exported.  
shouldExportRelationship(_relationship: Relationship): boolean Protected If true is returned, then the relationship will be exported.  
shouldExportSchema(_schemaKey: SchemaKey): boolean Protected If true is returned, then the schema will be exported.  

Defined in

Last Updated: 29 November, 2022