openFile MethodStatic

Open a read-only iModel snapshot.

openFile(path: string, opts?: SnapshotOpenOptions): SnapshotDb

see SnapshotDb.close

throws IModelError If the file is not found or is not a valid snapshot.

Parameter Type Description
path string the full path of the snapshot iModel file to open.
opts SnapshotOpenOptions  

Returns - SnapshotDb

Defined in

Last Updated: 29 November, 2022