GeometricModel3d Class

A container for persisting 3d geometric elements.

Extends

Extended by

Implements

Inherited methods

Name Inherited from Description
buildConcurrencyControlRequest(opcode: DbOpcode): void GeometricModel Add a request for the locks that would be needed to carry out the specified operation.
delete(): void GeometricModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void GeometricModel Call a function for each property of this Entity.
getJsonProperty(name: string): any GeometricModel  
getUserProperties(namespace: string): any GeometricModel Get a set of JSON user properties by namespace
insert(): string GeometricModel Insert this Model in the iModel
queryExtents(): Range3d GeometricModel Query for the union of the extents of the elements contained by this model.
removeUserProperties(nameSpace: string): void GeometricModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void GeometricModel  
setUserProperties(nameSpace: string, value: any): void GeometricModel Change a set of user JSON properties of this Element by namespace.
update(): void GeometricModel Update this Model in the iModel.
is(otherClass: undefined): boolean Static GeometricModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void ProtectedStatic GeometricModel Called before a Model is deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called when an Element in an instance of a Model of this class is about to be deleted.
onDeleted(_arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element in an instance of a Model of this class has been deleted.
onInsert(arg: OnModelPropsArg): void ProtectedStatic GeometricModel Called before a new Model is inserted.
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic GeometricModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onInserted(arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element has been inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void ProtectedStatic GeometricModel Called before a Model is updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic GeometricModel Called when an Element in an instance of a Model of this class is about to be updated.
onUpdated(arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element in an instance of a Model of this class has been updated.
populateRequest(req: ConcurrencyControl.Request, props: ModelProps, iModel: IModelDb, opcode: DbOpcode): void Static GeometricModel Disclose the codes and locks needed to perform the specified operation on this model

Properties

Name Type Description
isNotSpatiallyLocated Readonly boolean If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index.  
iSpatiallyLocated Accessor ReadOnly boolean    
isPlanProjection Readonly boolean If true, then the elements in this GeometricModel3d are expected to be in an XY plane.  
isSpatiallyLocated Accessor ReadOnly boolean If true, then the elements in this GeometricModel3d are in real-world coordinates and will be in the spatial index.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string GeometricModel The name of the BIS class associated with this class.
geometryGuid undefined | string GeometricModel  
id string GeometricModel The Id of this Entity.
iModel IModelDb GeometricModel The IModelDb that contains this Entity
isPrivate boolean GeometricModel  
isTemplate boolean GeometricModel  
jsonProperties Readonly { T } GeometricModel  
modeledElement Readonly RelatedElement GeometricModel  
name Readonly string GeometricModel  
parentModel Readonly string GeometricModel  
schema Static undefined GeometricModel The Schema that defines this class.
schemaName Accessor ReadOnly string GeometricModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 29 November, 2022