SQLiteDb Class

A SQLiteDb file

Implements

Methods

Name Description
constructor(): SQLiteDb    
abandonChanges(): void Abandon (cancel) the outermost transaction, discarding all changes since last save.  
closeDb(): void Close SQLiteDb.  
createDb(pathName: string): void Create a SQLiteDb  
dispose(): void Call this function when finished with this SQLiteDb.  
executeSQL(sql: string): DbResult execute an SQL statement  
openDb(pathName: string, openMode: OpenMode): void Open a SQLiteDb.  
saveChanges(): void Commit the outermost transaction, writing changes to the file.  
withPreparedSqliteStatement<T>(sql: string, callback: (stmt: SqliteStatement) => T): T Use a prepared SQL statement, potentially from the statement cache.  
withSqliteStatement<T>(sql: string, callback: (stmt: SqliteStatement) => T): T Prepared and execute a callback on a SQL statement.  

Properties

Name Type Description
isOpen Accessor ReadOnly boolean Returns true if the SQLiteDb is open  

Defined in

Last Updated: 29 November, 2022