DisplayStyleCreationOptions Interface
Describes initial settings for a new DisplayStyle3d. Most properties are inherited from DisplayStyle3dSettingsProps, but for backwards compatibility reasons, this interface is slightly awkward:
- It adds a
viewFlags
member that differs only in case and type from DisplayStyleSettingsProps.viewflags; and - It extends the type of DisplayStyleSettingsProps.backgroundColor to include ColorDef. These idiosyncrasies will be addressed in a future version of imodeljs-backend.
see DisplayStyle3d.create.
Extends
- Omit<DisplayStyle3dSettingsProps, "backgroundColor" | "scheduleScript">
Properties
Name | Type | Description | |
---|---|---|---|
backgroundColor | number | ColorDef | ||
viewFlags | undefined | ViewFlags | If supplied, the ViewFlags applied by the display style. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
analysisFraction | undefined | number | Omit | A floating point value in [0..1] representing the animation state of this style's analysisStyle. |
analysisStyle | undefined | AnalysisStyleProps | Omit | Settings controlling display of analytical models. |
ao | undefined | Props | Omit | Settings controlling display of ambient occlusion, stored in Props. |
backgroundMap | undefined | BackgroundMapProps | Omit | Settings controlling display of map within views of geolocated models. |
clipStyle | undefined | ClipStyleProps | Omit | Style applied by the view's ClipVector. |
contextRealityModels | undefined | ContextRealityModelProps[] | Omit | |
environment | undefined | EnvironmentProps | Omit | Settings controlling display of skybox and ground plane. |
excludedElements | string | Id64Array | Omit | Ids of elements not to be displayed in the view. |
hline | undefined | SettingsProps | Omit | Settings controlling display of visible and hidden edges. |
lights | undefined | LightSettingsProps | Omit | Settings controlling how the scene is lit. |
mapImagery | undefined | MapImageryProps | Omit | Map Imagery. |
modelOvr | undefined | DisplayStyleModelAppearanceProps[] | Omit | Overrides applied to the appearance of models in the view. |
monochromeColor | undefined | number | Omit | The color used in monochrome mode. |
monochromeMode | undefined | MonochromeMode | Omit | The style in which the monochrome color is applied. |
planProjections | undefined | { T } | Omit | Settings controlling how plan projection models are to be rendered. |
planarClipOvr | undefined | DisplayStylePlanarClipMaskProps[] | Omit | Planar clip masks applied to reality models. |
renderTimeline | undefined | string | Omit | The Id of a RenderTimeline element containing a RenderSchedule.Script that can be used to animate the view. |
solarShadows | undefined | SolarShadowSettingsProps | Omit | Settings controlling display of solar shadows, stored in Props. |
subCategoryOvr | undefined | DisplayStyleSubCategoryProps[] | Omit | Overrides applied to the appearances of subcategories in the view. |
thematic | undefined | ThematicDisplayProps | Omit | Settings controlling thematic display. |
timePoint | undefined | number | Omit | The point in time reflected by the view, in UNIX seconds. |
viewflags | undefined | ViewFlagProps | Omit | |
whiteOnWhiteReversal | undefined | WhiteOnWhiteReversalProps | Omit |
Defined in
- core/backend/src/DisplayStyle.ts Line 192
Last Updated: 11 June, 2024