viewFlags

Accessor

Flags controlling various aspects of the display style. To change the style's view flags, do something like:

```typescript const flags = settings.viewFlags.clone(); flags.renderMode = RenderMode.SmoothShade; // or any other alterations. settings.viewFlags = flags; @note Don't modify this object directly - clone it and modify the clone, then pass the clone to the setter.

viewFlags: ViewFlags

Returns - ViewFlags


Setter

Flags controlling various aspects of the display style. To change the style's view flags, do something like:

```typescript const flags = settings.viewFlags.clone(); flags.renderMode = RenderMode.SmoothShade; // or any other alterations. settings.viewFlags = flags; @note Don't modify this object directly - clone it and modify the clone, then pass the clone to the setter.

viewFlags(flags: ViewFlags): void

Parameter Type Description
flags ViewFlags  

Returns - void

Defined in

Last Updated: 29 November, 2022