MapLayerSettings Class

Normalized representation of a MapLayerProps for which values have been validated and default values have been applied where explicit values not defined. One or more map layers may be included within MapImagerySettings object.

see MapImagerySettings

Methods

Name Description
clone(changedProps: MapLayerProps): MapLayerSettings Create a copy of this MapLayerSettings, optionally modifying some of its properties.  
getSubLayerChildren(subLayer: MapSubLayerSettings): undefined | MapSubLayerSettings[] Return the children for a sublayer  
isSubLayerVisible(subLayer: MapSubLayerSettings): boolean Return true if sublayer is visible -- testing ancestors for visibility if they exist.  
setCredentials(userName?: string, password?: string): void    
subLayerById(id?: SubLayerId): undefined | MapSubLayerSettings Return a sublayer matching id -- or undefined if not found  
toJSON(): MapLayerProps return JSON representation of this MapLayerSettings object  
fromJSON(json?: MapLayerProps): undefined | MapLayerSettings Static Construct from JSON, performing validation and applying default values for undefined fields.  
fromMapSettings(mapSettings: BackgroundMapSettings): MapLayerSettings Static Create a MapLayerSettings object from the image settings within a BackgroundMapSettings object (providerName and mapType).  

Properties

Name Type Description
accessKey Readonly undefined | MapLayerKey    
allSubLayersInvisible Accessor ReadOnly boolean Return true if all sublayers are visible.  
formatId Readonly string    
isBase Readonly boolean    
name Readonly string    
password undefined | string    
subLayers Readonly MapSubLayerSettings[]    
transparency Readonly number    
transparentBackground Readonly boolean    
url Readonly string    
userName undefined | string    
visible Readonly boolean    

Defined in

Last Updated: 29 November, 2022