TerrainProps Interface

JSON representation of the settings of the terrain applied to background map display by a DisplayStyle.

see DisplayStyleSettingsProps

see BackgroundMapProps

Properties

Name Type Description
applyLighting undefined | boolean Applying lighting can help to visualize subtle terrain variation.  
exaggeration undefined | number A value greater than one will cause terrain height to be exaggerated/scaled.false (or 1.0) indicate no exaggeration.  
heightOrigin undefined | number Origin value - height of the IModel origin at the project center as defined by heightOriginMode.  
heightOriginMode undefined | TerrainHeightOriginMode Determines how/if the heightOrigin is applied to the terrain height.  
nonLocatable undefined | boolean   Deprecated  
providerName undefined | string Identifies the provider currently only CesiumWorldTerrain is supported.  

Defined in

Last Updated: 29 November, 2022