CalloutProps Interface

Extends

Properties

Name Type Description
drawingModel undefined | RelatedElementProps    

Inherited properties

Name Type Inherited from Description
category string GeometricElement2dProps The id of the category for this geometric element.
classFullName string GeometricElement2dProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code CodeProps GeometricElement2dProps The Code for this element
federationGuid undefined | string GeometricElement2dProps A FederationGuid assigned to this element.
geom undefined | GeometryStreamProps GeometricElement2dProps The geometry stream properties
id undefined | string GeometricElement2dProps The Id of the entity.
jsonProperties undefined | any GeometricElement2dProps Optional json properties of this element.
model string GeometricElement2dProps The Id of the Model containing this element
parent undefined | RelatedElementProps GeometricElement2dProps The Parent of this element, if defined.
placement undefined | Placement2dProps GeometricElement2dProps The placement properties
typeDefinition undefined | RelatedElementProps GeometricElement2dProps  
userLabel undefined | string GeometricElement2dProps A user-assigned label for this element.

Defined in

Last Updated: 29 November, 2022