Cartographic Class
A position on the earth defined by longitude, latitude, and height above the WGS84 ellipsoid.
Implements
Methods
Name | Description | |
---|---|---|
constructor(longitude: number = 0, latitude: number = 0, height: number = 0): Cartographic | ||
clone(result?: Cartographic): Cartographic | Duplicates a Cartographic. | |
equals(right: LatLongAndHeight): boolean | Return true if this Cartographic is the same as right | |
equalsEpsilon(right: LatLongAndHeight, epsilon: number): boolean | Compares this Cartographic component-wise and returns true if they are within the provided epsilon, | |
freeze(): Readonly<Cartographic> | Freeze this Cartographic | |
toEcef(result?: Point3d): Point3d | Return an ECEF point from a Cartographic point | |
toJSON(): LatLongAndHeight | ||
toString(): string | Create a string representing this cartographic in the format '(longitude, latitude, height)'. | |
fromAngles(longitude: Angle, latitude: Angle, height: number, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude in Angles. | |
fromDegrees(longitude: number, latitude: number, height: number, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude specified in degrees. | |
fromEcef(cartesian: Point3d, result?: Cartographic): undefined | Cartographic Static | Creates a new Cartographic from an ECEF position. | |
fromRadians(longitude: number, latitude: number, height: number = 0, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude specified in radians. | |
geocentricLatitudeFromGeodeticLatitude(geodeticLatitude: number): number Static | return the geocentric latitude angle for the input geodetic latitude angle (both in radians). | |
parametricLatitudeFromGeodeticLatitude(geodeticLatitude: number): number Static | return the parametric latitude angle for the input geodetic latitude angle (both in radians). | |
scalePointToGeodeticSurface(point: Point3d, result?: Point3d): undefined | Point3d Static | Scale point to geodetic surface |
Properties
Name | Type | Description | |
---|---|---|---|
height | number | ||
latitude | number | ||
latitudeDegrees Accessor ReadOnly | number | latitude, in degrees | |
longitude | number | ||
longitudeDegrees Accessor ReadOnly | number | longitude, in degrees |
Defined in
Last Updated: 11 June, 2024