BriefcaseDownloader Interface

Manages the download of a briefcase

Methods

Name Description
requestCancel(): Promise<boolean> Request cancellation of the download  

Properties

Name Type Description
briefcaseId number Id of the briefcase being downloaded  
downloadPromise Promise<void> Promise that resolves when the download completes.  
fileName string the name of the local file for the briefcase  

Defined in

Last Updated: 29 November, 2022